Attachments to plain text mail are always content/disposition inline

RESOLVED DUPLICATE of bug 65794

Status

MailNews Core
Composition
RESOLVED DUPLICATE of bug 65794
13 years ago
9 years ago

People

(Reporter: schmid, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7) Gecko/20040628 Firefox/0.9.1
Build Identifier: http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla1.7.2/mozilla-win32-1.7.2-installer.exe

When sending a plain text mail, attachments are always
"Content-Disposition: inline;", not "Content-Disposition: attachment;"

On some mail readers (e.g., Apple Mail on OS X, but also others) text files and
some other file types (e.g. .html, .tex) therefore do not appear as attachments
but as inline text and the text file cannot be saved to disk. The same problem
can also apply to images on some mail readers (Lotus). For text files, copy and
paste to a text editor is a workaround in some cases, but it does not help if
there is a large number of attachments, if it is unclear where one attachment
ends and the next one starts, or if the filenames of the attachments must be
accessible to the user (e.g., when sending several files containing program
sourcecode as attachments).

I think that some statements discussed as Bugzilla Bug 55657 refer to this
problem, but it has not been properly understood and handled. 

It is the same problem with Mozilla 1.5 and 1.7


Reproducible: Always
Steps to Reproduce:
1. create a new mail (Preferences: all domains plain text)
2. attach a file by dragging into the attachment box
3. send mail
4. view mail as source on the recipient's mailer

Actual Results:  
Example mail received (as raw source)

Return-Path: <schmid@iap.tuwien.ac.at>
Received: from [128.131.206.5] (128.131.206.5) by eaps4.iap.tuwien.ac.at (MX
          V5.3 AnDd) with ESMTP for <schmid@iap.tuwien.ac.at>;
          Wed, 1 Sep 2004 22:25:03 +0200
Message-ID: <4136313A.3050205@iap.tuwien.ac.at>
Date: Wed, 01 Sep 2004 22:29:46 +0200
From: Michael Schmid <schmid@iap.tuwien.ac.at>
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2)
            Gecko/20040803
X-Accept-Language: en-us, en, de-at, de
MIME-Version: 1.0
To: schmid@iap.tuwien.ac.at
Subject: test mit Mozilla 1.7
Content-Type: multipart/mixed; boundary="------------070402090609000003020108"



This is a multi-part message in MIME format.
--------------070402090609000003020108
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit

wieder drei Attachments

--------------070402090609000003020108
Content-Type: text/html;
 name="leis.html"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;       <<<<<<<<<<<<<<<here is the problem
 filename="leis.html"

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
        "http://www.w3.org/TR/html4/loose.dtd">
<HTML>
[....truncated]
</HTML>

--------------070402090609000003020108
Content-Type: text/plain;
 name="Berichte Venustransit-Ring.txt"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline;                 <<<<<<<<<<<<the same problem again
 filename="Berichte Venustransit-Ring.txt"



Hallo All,




Expected Results:  
The same with
"Content-Disposition: attachment;"
This should allow me (and other reciepients) to save the attached files to disk.

Comment 1

13 years ago
To change the attachment disposition type, you can add this to prefs.js:

  user_pref("mail.content_disposition_type", 1);

A text file will still be viewed inline in Mozilla, unless the View menu option 
is turned off.

*** This bug has been marked as a duplicate of 65794 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.