Taskbar icons all the same (moz head) instead of functional icons (browser vs. mail)

VERIFIED FIXED in mozilla1.8beta1

Status

--
critical
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: lohphat, Assigned: darin.moz)

Tracking

({regression})

Trunk
mozilla1.8beta1
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040908
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040908

See summary

Reproducible: Always
Steps to Reproduce:
1. Install 20040908 win32 build.

Actual Results:  
The app works ok, but the win32 taskbar icons are all identical. (XP) Modern skin.

Expected Results:  
Browser, mail, composer, etc. icons should be different.

Comment 1

14 years ago
Confirming with two Linux builds (one Gtk1, the other Gtk2) I just finished
compiling. I'm seeing the standard X icon for all Mozilla windows.

My last builds were three or four days old and didn't have this bug.
Assignee: general → jag
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: Installer → XP Apps
Ever confirmed: true
Flags: blocking1.8a4?
Keywords: regression
OS: Windows XP → All
QA Contact: bugzilla → pawyskoczka
Hardware: PC → All

Comment 2

14 years ago
Backing out attachment 157837 [details] [diff] [review] from Bug 257162 fixes the bug.

Assignee: jag → darin
(Assignee)

Updated

14 years ago
Severity: normal → critical
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.8beta
(Assignee)

Comment 3

14 years ago
Created attachment 158234 [details] [diff] [review]
v1 patch

Untested patch, but very likely to do the trick.  I'm building seamonkey now to
verify this patch.
(Assignee)

Comment 4

14 years ago
Comment on attachment 158234 [details] [diff] [review]
v1 patch

NS_APP_CHROME_DIR_LIST is optional.  this patch makes it so.
Attachment #158234 - Flags: review?(cbiesinger)
(Assignee)

Updated

14 years ago
Blocks: 257162
Attachment #158234 - Flags: review?(cbiesinger) → review+
(Assignee)

Comment 5

14 years ago
fixed-on-trunk
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Flags: blocking1.8a4?

Comment 6

14 years ago
Verified with a Gtk1 build I just made. Thanks Darin! :-)
Status: RESOLVED → VERIFIED

Comment 7

14 years ago
*** Bug 258627 has been marked as a duplicate of this bug. ***
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.