Closed Bug 258496 Opened 16 years ago Closed 4 years ago

Number of concurrent downloads limited to 4

Categories

(Core :: Networking, defect)

x86
Windows XP
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: bugzilla, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

When using the ctrl-click feature to open multiple links in new tabs, it happens
that the browser stops loading pictures in all but one or two tabbed windows.


Reproducible: Always
Steps to Reproduce:
Not easily described. Try to open a site with many links to different web sites.
news.google.com might qualify. Then, use ctrl-click to open 10-12 tabbed
windows. This would likely demonstrate the effect.

Actual Results:  
Browser stops loading tabbed windows because the maximum number of simultaneous
download slots are taken (appears to be 4).

One tab may be loading but all other are stalled at showing just html and no images.


Expected Results:  
There is a spec that says that no browser should open more than 4 simultaneous
connections to any single http server at a time.

Firefox seems to have a bug in this area, because it appears to stop *all*
downloads if *one* web site is receiving 4 simultaneous downloads. For example,
one slot may have 4 connections to the same http server, while another tab to a
completely sifferent site is unable to complete (download images for example)
because the browser assumes that tab is accessing the same site as the first one.

It's a bit complicated to explain but it does appear that Firefox has some kind
of bug regarding multiple, simultaneous downloads (http requests). I hope this
is enough information to identify the relevant code and check for errors - even
if you aren't able to immediately reproduce what I am speaking of.


I just remembered that the same results can be seen with 4 simultaneous "real"
downloads (i.e. entries in the Download manager window). In this case all other
activity seems to stop as well.
limitation set by the server not the browser
->INVA
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
Nonsense. Nonsense AGAIN. I can't believe I spend all that time writing a
quality report only to get this type of indifferent no-response. One whole line?
I mean come on!

Firefox is a great browser but the level of quality from the community has so
far been less than uplifting to say the least.

Anyway. Back on topic.

I was able to find out through other channels that about:config has a number of
http, network and connection related settings that directly affect how the
browser  accesses web servers. THAT is why the browser seems to go dead after
four simultaneous connections.

Status changed to Reopen for this reason: I believe the defaults should be made
higher, because the default limits seem to be hit very easily and affect
browsing performance negatively - leaving users with no other choice but to open
another browser to continue surfing. This just isn't very smart.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
(In reply to comment #1)
> limitation set by the server not the browser
> ->INVA

Bull.  It happens to me as well with PR1 to an even more extreme measure.  Even
if I just sit at a web site and do nothing, I can only download two items at
once.  If I attempt to start downloading a third, Firefox will just sit there
until one of the two is completed at which point the third one starts.

This was fine back in the day when 56K modems ruled the earth.  But now in the
days of broadband and corporapte T1s, T3s, and more, this kind of restriction is
beyond unacceptable.
Reporter - there is a seperate setting for max-connections and
max-connections-per-server.

Were you exceeding the former? If not this doesn't sound like intended behaviour.

re Comment#3

Not only is your problem something entirely different from this bug, your
attitude sucks. I suggest you look at bug 83526 and carefully read (a)the
description and (b) comment 44.

Then come back and apologise about 'beyond unacceptable'
Over to Networking:HTTP.

Are you still having a problem with a recent version of Firefox?  Are the limits
your seeing matching up with what's set in the prefs? (if I'm understanding
correctly, 4 would be the limit if you were using a proxy with keep-alive enabled).
Assignee: firefox → darin
Component: General → Networking: HTTP
Product: Firefox → Core
QA Contact: general → networking.http
Version: unspecified → 1.7 Branch
We probably don't distinguish between connections for downloads and connections
for browsing.
Summary: Number of concurrent downloads incorrectly limited to 4 → Number of concurrent downloads limited to 4
*** Bug 302315 has been marked as a duplicate of this bug. ***
(In reply to comment #7)
> *** Bug 302315 has been marked as a duplicate of this bug. ***

My bug was a specific manifestation of this bug (specifically, multiple
downloads are mysteriously just-not-started).  If Firefox is going to impose
this limit (which is a reasonable default, at least), it *absolutely should not*
do so silently and invisibly to the user!  It should instead queue up the
download but simply mark it as "queued" or something similar to 1) let the user
know that Firefox understood the mouse click and 2) keep the user from having to
poll the Firefox window in order to start the nth download.
-> default owner
Assignee: darin → nobody
Component: Networking: HTTP → Networking
QA Contact: networking.http → networking
Version: 1.7 Branch → Trunk
the download manager queues things now... there will always be some kind of connection limit, but h2 makes this much better
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.