URLs from other apps containing pipe (|) make Firefox open multiple tabs

RESOLVED DUPLICATE of bug 221445

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED DUPLICATE of bug 221445
14 years ago
14 years ago

People

(Reporter: Robert, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The application that I use for my mail lists provides link tracking. The URL
provided is a sample link. When a user clicks the link in their mail client and
Firefox launches, it opens up 13 tabs with apparantly random Web pages coming up
under each tab. 

If you just paste the link into the Address bar of Firefox and press enter, it
performs as expected. This problem only occurs when a link like this is clicked
outside of Firefox and Firefox is the default browser.

Reproducible: Always
Steps to Reproduce:


1. Set Firefox set as your default browser. 

2. Go to any Web page and drag the icon to the left of the address in the
address bar to the desktop and create a link shortcut.

3. Right click the link shortcut and choose 'porperties'. Change the URL to
under the Web document tab to
http://www.webproclaim.com/mailapp/lt/t_go.php?i=145&e=aW5mb0B3ZWJwcm9jbGFpbS5jb20=&l=http://www.answersingenesis.org/onlinestore/gateway.asp|Q|PageType|E|detail|A|UID|E|10-2-001|Q|srcFrom|E|aignews

4. Click OK. Now double click the short cut. Firefoc\x will launch with 13+ tabs
opening automatically with apparantly radnom Web pages. 

Also, if you just paste in the same URL into the address bar and press enter, it
works as expected. 

This problem will occur any time links of this nature are called from OUTSIDE of
Firefox and Firefox is the default browser. 
Actual Results:  
Firefox will open 13+ tabs with (random?) Web pages.

Expected Results:  
Open the URL and behaved teh same way as if the user had just typed that adderss
in the address bar and pressed enter.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 221445 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Summary: The URL when clicked outside of Firefox, launches multiple tabs inside of Firefox. → URLs from other apps containing pipe (|) make Firefox open multiple tabs
You need to log in before you can comment on or make changes to this bug.