option to turn off pasting URLs by middle mouse button

RESOLVED DUPLICATE of bug 135884

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 135884
15 years ago
5 years ago

People

(Reporter: jakub.suder, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040823 Firefox/0.9.3

I think it would be useful if there was an option to disable the function to
paste URLs into browser using middle mouse button. It often happens to me that I
try to click a link with middle mouse button to open that page in new tab, but
instead I click few pixels away from the link; then instead of opening the right
page in new tab, Firefox tries to open some non-existing page in the current
tab. I don't use the function "open in current tab the page which URL is
currently in clipper", and I use the function "open link in new tab" very often,
so I'd like to turn off the former, because these situations like described
above annoy me a bit ...

Reproducible: Always
Steps to Reproduce:
1. click middle mouse button somewhere on a web page (not on a link)

Actual Results:  
Firefox tries to load a page which URL is equal to text which is currently
copied into clipper.

Expected Results:  
Some people may like this behaviour, but I'd like to be able to disable it -
middle mouse button click would then work only on links, and if you click
elsewhere - it wouldn't do anything at all.

Comment 1

15 years ago
Don't set OS to ALL unless you know it affects all systems.  Pasting is
defaulted to off on non-Linux systems.  The option you want (Access from
about:config) is middlemouse.paste

Should this be duped to bug 171132?
OS: All → Linux
no, this is either INVALID or WONTFIX.

This is just another convention on Linux that new users hate.  I don't like it
myself.

the contentLoadURL pref would also need to be changed, iirc
(Reporter)

Comment 3

15 years ago
Or better, bug 135884 or bug 85677 - that's exactly the same bug (or  
"feature"...). As for now, I'll try to turn it off in those hidden  
preferences. Although I generally believe that things that half of users like  
and the other half don't, should be put into preferences to let all users  
decide how they want it.  

Comment 4

15 years ago
This is already reported. Please help us keep the Bugzilla database in order by
finding the original bug and marking this a duplicate of that. Thanks.
Whiteboard: DUPEME
(Reporter)

Comment 5

15 years ago

*** This bug has been marked as a duplicate of 135884 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences

Updated

5 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.