xml prettyprint does not work with 0.9.3 or mozilla1.7.2

RESOLVED DUPLICATE of bug 259206

Status

()

Firefox
File Handling
RESOLVED DUPLICATE of bug 259206
13 years ago
13 years ago

People

(Reporter: Joe Roback, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040910 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040910 Firefox/0.9.3

I recieve these WARNINGS when loading an XML document with firefox:
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsSyncLoadService.cpp,
line 401
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsXMLPrettyPrinter.cpp,
line 146

Prettyprint does not work for me with:
Firefox 0.9.3
Mozilla 1.7.2

I tried making new profiles, etc, etc, as listed in other bugzilla tickets, but
no luck. user config layout.xml.prettyprint is true also.

I use Gentoo Linux. I tried the gentoo packages and the installer from
mozilla.org, no luck.

I use Gentoo @ home also, basically the same setup as my work machine, and XML
prettyprinting works!  I cannot figure out the difference... Does xml
prettyprint depend on some external library?

Reproducible: Always
Steps to Reproduce:
1. Load any XML document ( no stylesheet applied, raw XML )
2. With compiled with debug enabled, console shows: 
3. Rinse and repeat.

Actual Results:  
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsSyncLoadService.cpp,
line 401
WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv)) failed, file nsXMLPrettyPrinter.cpp,
line 146

XML document is not printed propertly

Expected Results:  
XML document should be displayed in the prettyprint mode

Gentoo Linux
gcc-3.3.4
glibc-2.3.3.20040420-r1
uname -a = Linux stadjrobalin 2.6.8-gentoo-r3 #1 Wed Sep 8 10:42:49 PDT 2004
i686 Intel(R) Pentium(R) 4 CPU 2.80GHz GenuineIntel GNU/Linux
(Reporter)

Comment 1

13 years ago
My 2 computer about:buildconfig

my home gentoo computer which works with XML prettyprint:
about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler        Version         Compiler flags
gcc     gcc version 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2,
pie-8.7.6)      -Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-march=athlon-xp -pipe -mmmx -msse -m3dnow -mfpmath=sse -fprefetch-loop-arrays
-fforce-addr -falign-functions=4 -Wno-return-type -w -Wno-return-type -w
-Wno-return-type -w -fno-stack-protector -s -fforce-addr -pthread -pipe
g++     gcc version 3.3.3 20040412 (Gentoo Linux 3.3.3-r6, ssp-3.3.2-2,
pie-8.7.6)      -frtti -fno-handle-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -march=athlon-xp -pipe -mmmx -msse -m3dnow
-mfpmath=sse -fprefetch-loop-arrays -fforce-addr -falign-functions=4
-Wno-return-type -w -Wno-return-type -w -Wno-return-type -w -s -fforce-addr
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --enable-optimize=-O2 --disable-composer --with-x
--with-system-jpeg --with-system-zlib --with-system-png --with-system-mng
--disable-mailnews --disable-calendar --disable-pedantic --disable-svg
--enable-mathml --without-system-nspr --enable-nspr-autoconf --enable-xsl
--enable-ipv6 --enable-crypto --with-java-supplement --with-pthreads
--with-default-mozilla-five-home=/usr/lib/MozillaFirefox
--with-user-appdir=.phoenix --disable-jsd --disable-accessibility
--disable-tests --disable-debug --disable-dtd-debug --disable-logging
--enable-reorder --enable-strip --enable-strip-libs --enable-cpp-rtti
--enable-xterm-updates --disable-ldap --disable-toolkit-qt
--disable-toolkit-xlib
--enable-extensions=default,-irc,-venkman,-content-packs,-help
--enable-toolkit-gtk2 --enable-default-toolkit=gtk2 --disable-toolkit-gtk
--enable-xft --disable-freetype2 --enable-xinerama=yes
--enable-old-abi-compat-wrappers
-- 

my work gentoo computer which DOES NOT work with XML prettyprint:
about:buildconfig

Build platform
target
i686-pc-linux-gnu

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-Wall -W -Wno-unused -Wpointer-arith -Wcast-align -Wno-long-long
-march=pentium4 -pipe -pthread -pipe
g++ 	gcc version 3.3.4 20040623 (Gentoo Linux 3.3.4-r1, ssp-3.3.2-2,
pie-8.7.6) 	-fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith
-Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -march=pentium4 -pipe -Wno-deprecated
-fshort-wchar -pthread -pipe -I/usr/X11R6/include

Configure arguments
--prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man
--infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc
--localstatedir=/var/lib --enable-optimize=-O2 --enable-old-abi-compat-wrappers
--disable-activex --disable-activex-scripting --disable-installer
--disable-pedantic --enable-crypto --enable-mathml --enable-xterm-updates
--with-pthreads --with-system-jpeg --with-system-png --with-system-zlib --with-x
--without-system-nspr --enable-ipv6 --enable-ldap --enable-ldap-experimental
--enable-xinerama --enable-xprint --enable-gnomevfs
--enable-default-toolkit=gtk2 --disable-debug --disable-tests --enable-reorder
--enable-strip --enable-strip-libs --enable-elf-dynstr-gc --enable-xft
--enable-freetype2 --enable-freetypetest --enable-jsd --enable-xpctools
--enable-oji --disable-mailnews --disable-calendar --disable-svg
--enable-extensions=cookie,inspector,negotiateauth,pref,transformiix,typeaheadfind,universalchardet,webservices,xmlextras,xml-rpc,venkman,gnomevfs
--with-default-mozilla-five-home=/usr/lib/MozillaFirefox
(Reporter)

Comment 2

13 years ago
http://forums.gentoo.org/viewtopic.php?t=200131

Problem seems to be rooted in freedesktop.org's mapping of .xsl files NOT to the
mime type of text/xml...

I follow the simple instructions in the 5th post in above listed forum, changing
.xsl to mime-type text/xml and bingo it works.

What needs to be done to get this to work by default? Is it a firefox or
freedesktop.org change?

Comment 3

13 years ago
Related to/duplicate of bug 259206?

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 259206 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.