Personal Toolbar: Not all context menu items are available when right clicking

VERIFIED FIXED

Status

()

--
major
VERIFIED FIXED
14 years ago
7 years ago

People

(Reporter: marcia, Assigned: vlad)

Tracking

({fixed-aviary1.0})

1.0 Branch
fixed-aviary1.0
Points:
---
Bug Flags:
blocking-aviary1.0 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Comment 1

14 years ago
Seen while testing Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; rv:1.7.3)
Gecko/20040910 Firefox/0.10. Affects all platforms.

STR:

1. Launch a fresh instance of the browser.
2. Place cursor in personal toolbar area and then right click to launch context
menu.
3. Observe that numerous menu selections are grayed out and not available for
selection.

I create new folders quite a bit in the personal toolbar and would expect that I
could do so by clicking anywhere in the personal toolbar area. Also, if you
click on an existing bookmark it seems as if it enables the entire context menu.

Tracy and I are investigating if this is a regression.

Comment 2

14 years ago
I narrowed this regression down to a window of between the builds on
2004-08-17-08 and 2004-08-18-08

specifically, the context menu items that regressed are:
-New Bookmark...
-New Folder...
-New Seperator...

In addition to Marcia's comments.  These items in the context menu remain
enabled until restart.  On Restart they are again grey out.  Before the
regression, on restart, these item would not be greyed out.
Assignee: bugs → vladimir
Component: Toolbars → Bookmarks
Keywords: regression
Hardware: Macintosh → All
(Reporter)

Comment 3

14 years ago
Still seeing this behavior on Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O;
en-US; rv:1.7.3) Gecko/20040928 Firefox/0.10. When I right click on the personal
toolbar, all menu items are grayed out except for Expand | Open in tabs |Manage
Folder |Properties.

Sarah reports she also is seeing this in today's Linux build and I just verified
that this is happening on Windows XP as well.
(Reporter)

Comment 4

14 years ago
nominating.
Flags: blocking-aviary1.0?
Status: NEW → ASSIGNED

Comment 5

14 years ago
Any new window shows the bug.  

workaround to get the menu items to appear is to context click an existing
bookmark in the bookmark toolbar.  From then on, that window will have the
proper items available.

Comment 6

14 years ago
vlad, is there a way to fix this regression?
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Created attachment 161093 [details] [diff] [review]
258787-ptf-not-all-items-available-0.patch

This is somewhat of a bandaid, but a working one; right-clicks on the ptf
portion don't go through BookmarksMenu.js, so we don't get the _target/aTarget
setting that we'd normally get for the controller.  So, the PTF gets special
cased here.
Attachment #161093 - Flags: review?
Attachment #161093 - Flags: approval-aviary?
Attachment #161093 - Flags: review? → review?(bugs)
*** Bug 262924 has been marked as a duplicate of this bug. ***
Comment on attachment 161093 [details] [diff] [review]
258787-ptf-not-all-items-available-0.patch

r+a=ben@mozilla.org
Attachment #161093 - Flags: review?(bugs)
Attachment #161093 - Flags: review+
Attachment #161093 - Flags: approval-aviary?
Attachment #161093 - Flags: approval-aviary+
fixzored on aviary.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Keywords: regression → fixed-aviary1.0
Resolution: --- → FIXED
Verified with Mac build 2004-10-05-06-0.9
Status: RESOLVED → VERIFIED

Updated

13 years ago
QA Contact: bugzilla → bookmarks
You need to log in before you can comment on or make changes to this bug.