Bring back chrome bar below tabs

RESOLVED FIXED

Status

()

Firefox
Tabbed Browser
--
minor
RESOLVED FIXED
13 years ago
12 years ago

People

(Reporter: sgarrity, Assigned: Kevin Gerich)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

51.23 KB, image/jpeg
Details
(Reporter)

Description

13 years ago
With the landing of the (great) Winstripe theme, there was a change to the
bottom of tabs in Firefox. Before Winstripe, there was a divider between the
bottom of the tabs and the start of the web page. Now, there is no divider.

While this looks ok initially with a web-site with a white-background, I think
we should bring back the divider.

Pinstripe on Mac OS X handles this nicely with a divider below the tabs and
above the page content area (screenshot:
http://actsofvolition.com/images/screenshots/firefox_mac_tabs.png).

With Winstripe on Windows and Gnome now, the page runs right into the bottom of
the tabs:
Current windows screenshot:
http://actsofvolition.com/images/screenshots/firefox_win_tabs.png
Current Gnome screenshot:
http://actsofvolition.com/images/screenshots/firefox_gnome_tabs.png

Here's how it looked before Winstripe landed (Qute):
http://actsofvolition.com/images/screenshots/firefox_qute_tabs.png

I think it should have a divider for the following reasons:
- The edge looks rough agains non-white backgrounds
 When scrolling, there's not solid edge for the page to slide behind. This is
especially apparant when text on a white background is sliding under the tabs -
you can get half of a line of text showing and it looks oddly cut-off.
- The web page portion of the browser should be squarely framed - any opening in
that breaks up the page and can conflict with page contents.
(Assignee)

Comment 1

13 years ago
fixed on branch
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 2

13 years ago
Only branch fix? If yes, then this should be reopened and the keyword
fixed-aviary1.0 should be added.
(Assignee)

Comment 3

13 years ago
quite right. my bad
Status: RESOLVED → REOPENED
Keywords: fixed-aviary1.0
Resolution: FIXED → ---
Kevin, this was just and only for Windoze , right ?
(bug OS = Linux)
(Assignee)

Comment 5

13 years ago
As far as I know this affects Windows and Linux which both share the piece of
the Winstripe theme that I modified. I did test my patch on a variety of
platforms and it seemed to work fine in a GTK build.
(In reply to comment #5)
> As far as I know this affects Windows and Linux which both share the piece of
> the Winstripe theme that I modified. I did test my patch on a variety of
> platforms and it seemed to work fine in a GTK build.

Don't worry, it works fine on Win32 too.

vrfy'd fixed on the branch using 2004102009-0.9+ on linux fc2 (gnome).

Comment 8

13 years ago
For those who prefer the somewhat more polished way Qute did this, the necessary
additions to userChrome.css at the time of writing are:

#content .tabbrowser-strip {
  border-bottom: 1px solid ThreeDShadow;
  padding-bottom: 1px;
}
#content .tabbrowser-tabs {
  border-bottom: 0 !important;
  padding-left: 0 !important;
  background: none !important;
}
#content .tabs-left,
#content .tabs-right {
  border-bottom-width: 1px !important;
}
#content tab {
  margin-bottom: 0 !important;
}

Comment 9

13 years ago
Created attachment 162978 [details]
Screenshot

Was it this fix that added a grey line under the tabs? In other parts of the
system, tabs dont have any underline.

Is it supposed to look like that?
(Assignee)

Comment 10

13 years ago
Yes it's supposed to look like that. I know other tabs don't have the same look,
but the other tabs don't border browser content either.

Comment 11

13 years ago
Ah ok, personally this always bugged me with the classic theme on mozilla suite
and really enjoyed the way Firefox looked.

Now when i had a look at the MAC screenshot i see it looks better there. If we
have this line, can't we add an extra pixel to match the MAC theme? The line
makes more sence with that extra pixel. Its clearer. 
(Assignee)

Comment 12

13 years ago
It's a bit difficult to make the Winstripe browser tabs look as good as
Pinstripe, because with Pinstripe I use my own design which I have control over
for the most part. For Winstripe, you have the bar at the bottom and native
OS-drawn tabs on top. It's tough to get the bar to blend with the tabs when you
can't count on knowing what the tabs will look like. I think I've achieved a
compromise that looks good on Luna and is acceptable on Classic and Linux. 

Of course there's always room for improvement. If anyone would like to submit
ideas, I'm willing to consider them :)

Comment 13

13 years ago
Created attachment 163342 [details]
Screenshot

What about adding an extra pixel to make it even more clearer? Like the mac os
x version.
Attachment #162978 - Attachment is obsolete: true

Comment 14

13 years ago
I just downloaded Firefox 1.0 and I prefer previous tab design, without bottom
border, because I find it "lighter". I think the design with a border below the
tabs is confusing. What do you think?
(Reporter)

Comment 15

13 years ago
Why was this REOPENED? The chrome bar is back, so this is fixed.

Requests for the chrome bar to be removed should be another bug (and then marked
as WONTFIX)  ;-)
Indeed, this is a passed discussion
->RESOLVED/FIXED
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 17

13 years ago
It was reopened because the fix for this initially landed on the Branch, not on
the trunk. I believe the fix for this came over to the trunk in Ben's Big Merge.
The fixed-aviary1.0 bugs should be tested on the trunk before they are closed.
Oops,
I see the same tab layout in Aviary/trunk so I assumed it was reopened by the
guy from comment #14 .
(Reporter)

Comment 19

13 years ago
I can confirm that this is fixed in the 19-Dec-2004 nightly for linux which I
presume means it has been landed on the branch - so I think this can stay FIXED.
You need to log in before you can comment on or make changes to this bug.