Closed Bug 259019 Opened 18 years ago Closed 18 years ago

Unchecking "Save information I enter in web page forms and the search bar" prevents password autocomplete dropdown

Categories

(Toolkit :: Password Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 258543

People

(Reporter: tiddles+bmo, Assigned: bryner)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.3) Gecko/20040910 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910 Firefox/0.10

Unchecking the preference "Save information I enter in web page forms and the
search bar" (browser.formfill.enable) correctly prevents form autocomplete, and
also correctly allows single usernames and passwords to appear in a form on page
load, provided "Remember Passwords" is checked.

However, if a second login is available for the same form, the autocomplete
dropdown which should allow the user to select between the logins never appears
if browser.formfill.enable is set to false.

Essentially, it appears that autocomplete is being entirely disabled when
browser.formfill.enable is set to false.  This isn't a good idea, since
autocomplete is now required for passwords as well as normal form autocomplete.
 Firefox should either always enable autocomplete (which doesn't break the the
existing formfill-disabling functionality, since form information is never so
much as saved with that pref set) or check both browser.formfill.enable _and_
signon.rememberSignons before disabling autocomplete.

Reproducible: Always
Steps to Reproduce:
1. In Options - Privacy - Saved Form Information, uncheck "Save information I
enter in web page forms and the search bar".  Now open the Saved Passwords
section, and check "Remember Passwords"
2. Visit a page with a login form for which Password Manager will remember values.
3. Enter a login, and have Firefox remember it.
4. Return to the login page.  Password Manager correctly autofills the login you
saved.
5. Enter a different login, and have Firefox remember that as well.
6. Return to the login page again, and try to make the autocomplete dropdown
appear to select a login (down arrow, begin typing a login, etc.)
Actual Results:  
It is not possible to make an autocomplete dropdown appear.  However, if one of
the login names is typed out in full, tabbing to the password field will
autofill the password.

Expected Results:  
The autocomplete dropdown should appear and allow selection between the logins.
Flags: blocking-aviary1.0?
Dupe of Bug 258543.

*** This bug has been marked as a duplicate of 258543 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Flags: blocking-aviary1.0?
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.