Enable multiple extensions/themes selection (for Update checking, disabling or uninstalling)

REOPENED
Unassigned

Status

()

enhancement
P3
normal
REOPENED
15 years ago
21 days ago

People

(Reporter: goodvin, Unassigned)

Tracking

unspecified
Points:
---
Dependency tree / graph
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040911 Firefox/0.10

In EM/TM, there is normally only one item is selected. Up until today I was
wondering why it is so, and why I can't select multiple items to check for
updates. It took a mozillazine post and Asa's reply to enlighten me that to
check for updates for all items, I need to _unselect_ all items.

It will be more intuitive to have multiple selections enabled as well. Selecting
multiple items would allow new functionality as well - to check for updates for
any desired combination of extensions/themes at once.

Reproducible: Always
Steps to Reproduce:
Hold ctrl and click on different extensions/themes.
Actual Results:  
Any selection disappears.

Expected Results:  
Clicked extensions/themes stay selected, and Update button is enabled.
Yes, selecting multiple items is needed.
To us the users, it seems as if by default it will not update any, as though
they are listed they are not selected. So I tried to select them all, but could
only select one, and it only checked one. I thought you had to go through all
the process again, for every single extension... definetly the current system is
not user intuitive.

Have all selected by default, and allow us to select them all.
A button to check all extensions/themes for updates might be a good alternate
solution.  This would prevent possibly causing a problem for the options button
with multiple extensions selected.  However, allowing multiple items to be
selected allows the possibility to uninstall more than one extension at a time.

Either way, it needs to be more clear how to check for updates to all installed
extensions/themes.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-aviary1.0?
You can do a full check from Tools -> Options -> Advanced -> Software Update
[Check Now] but that's fairly burried. I think we do want multiple selection.
Advanced users (the ones that will be mucking around in the EM) will expect this
behavior and lacking it in no way makes "select none is the same select all"
obvious.  

Ben's the man on these kinds of issues, so I hope he'll chime in soon. 
Flags: blocking-aviary1.0? → blocking-aviary1.0+
Not a "blocker"
Flags: blocking-aviary1.0+ → blocking-aviary1.0-
This would be also be useful for disabling or uninstalling multiple extensions
at once. I'm taking the liberty of morphing this bug to be more general.
Makes sense to me, bug if anybody thinks it's inappropriate, I'll change it back.
Severity: normal → enhancement
OS: Windows XP → All
Hardware: PC → All
Summary: Enable multiple extensions/themes selection for Update checking → Enable multiple extensions/themes selection (for Update checking, disabling or uninstalling)
Blocks: 265154
*** Bug 263094 has been marked as a duplicate of this bug. ***
Assignee: bugs → nobody
QA Contact: bugs → extension.manager
This is no longer an issue, the find updates button checks for updates on all themes/extensions

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.6) Gecko/20060805 Firefox/1.5.0.6
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → WORKSFORME
(In reply to comment #7)
> This is no longer an issue, the find updates button checks for updates on all
> themes/extensions

Multiple selection is useful for many other things besides finding updates. Please read the summary and the comments.

Reopening.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Hooray, blocking bug 298371 has been fixed :-)
Product: Firefox → Toolkit
Duplicate of this bug: 265154
Duplicate of this bug: 537395
Duplicate of this bug: 686408
Duplicate of this bug: 872820
Duplicate of this bug: 873370
Priority: -- → P3
You need to log in before you can comment on or make changes to this bug.