If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[talkback] random but high hit crash in cache code?

CLOSED FIXED in M14

Status

()

Core
Networking: Cache
P3
critical
CLOSED FIXED
18 years ago
18 years ago

People

(Reporter: chris hofmann, Assigned: davidm)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Must fix 02/25 Have purposed fix ready to check in.)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
several hits in the m13 talkback reports with a stack that looks like
this.

nsHTTPChannel::~nsHTTPChannel 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
124]
nsHTTPChannel::`scalar deleting destructor'
nsHTTPChannel::Release 
[d:\builds\seamonkey\mozilla\netwerk\protocol\http\src\nsHTTPChannel.cpp, line 
133]
nsCOMPtr_base::~nsCOMPtr_base 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 45]
CacheManagerStreamListener::~CacheManagerStreamListener
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCacheEntryChannel.cpp, line 
228]
CacheManagerStreamListener::`scalar deleting destructor'
CacheOutputStream::Release 
[d:\builds\seamonkey\mozilla\netwerk\cache\mgr\nsCacheEntryChannel.cpp, line 90]
nsCOMPtr_base::assign_with_AddRef 
[d:\builds\seamonkey\mozilla\xpcom\base\nsCOMPtr.cpp, line 54]
nsOnStopRequestEvent::HandleEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
279]
nsStreamListenerEvent::HandlePLEvent 
[d:\builds\seamonkey\mozilla\netwerk\base\src\nsAsyncStreamListener.cpp, line 
94]
PL_HandleEvent [plevent.c, line 527]
_md_EventReceiverProc [plevent.c, line 977]
USER32.dll + 0x124c (0x77e7124c)
(Reporter)

Comment 1

18 years ago
Created attachment 4748 [details]
m13 top sig #3 comment report
(Reporter)

Comment 2

18 years ago
over to warren?
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/netwerk/protocol/http/src/ns
HTTPChannel.cpp
Assignee: gagan → warren
Summary: [talkback] random but high hit crash in cache code? → [talkback] random but high hit crash in cache code?
(Reporter)

Comment 3

18 years ago
any ideas?

Updated

18 years ago
Target Milestone: M14

Comment 4

18 years ago
I bet this is the stray OnStopReqeust().
Assignee: warren → gagan

Comment 5

18 years ago
cache->gordon/davidm
Assignee: gagan → gordon

Comment 6

18 years ago
Adding "crash" keyword.
Keywords: crash
(Reporter)

Updated

18 years ago
Keywords: beta1

Comment 7

18 years ago
Putting on PDT+ radar for beta1.
Whiteboard: [PDT+]

Updated

18 years ago
Severity: normal → critical

Comment 8

18 years ago
Has this been seen on Win98 or NT?
Status: NEW → ASSIGNED
Whiteboard: [PDT+] → [PDT+] 2/14/2000
(Reporter)

Comment 9

18 years ago
rough look at the data from talkback show that its 
exclusively NT bld 1381.  how's that for an answer ;-)
attachment update showing platform info to follow in a 
minute..
(Reporter)

Comment 10

18 years ago
Created attachment 5091 [details]
platform info for this crash

Comment 11

18 years ago
The talkback incident reports are dead links! 

I say change NS_RELEASE(mRequest);
to           NS_IF_RELEASE(mRequest);
and call it a day.
(Assignee)

Comment 12

18 years ago
sounds good to me.
Assignee: gordon → davidm
Status: ASSIGNED → NEW

Comment 13

18 years ago
2/14/2000 is over. Need new date.
Whiteboard: [PDT+] 2/14/2000 → [PDT+]

Comment 14

18 years ago
warren, can you fix by 02/25?  
Whiteboard: [PDT+] → [PDT+] Must fix 02/25
(Assignee)

Updated

18 years ago
Whiteboard: [PDT+] Must fix 02/25 → [PDT+] Must fix 02/25 Have purposed fix ready to check in.

Comment 15

18 years ago
Arrrrggg!!!  This looks like yet another dup of bug #21556.
(Assignee)

Comment 16

18 years ago
Marking fixed since someone checked in the code I was going to. As rick says 
this is probably a dup.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 17

18 years ago
Discussed with rpotts.  This is apparently a dupe of bug 21556.  Closing
and supplying link.
Status: RESOLVED → CLOSED
You need to log in before you can comment on or make changes to this bug.