XSLT engine rejects local stylesheets as MIME type deemed incorrect

RESOLVED INVALID

Status

()

Core
XSLT
RESOLVED INVALID
14 years ago
14 years ago

People

(Reporter: Luke Ross, Assigned: peterv)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040808 Firefox/0.9.3

On Fedora Core 2, an attempt to XSLT-process a local XML document and stylesheet
fails because the XSL stylesheet does not have a text/xml mimetype. The mozilla
installer picks up a MIME type for stylesheets of text/x-xslt from the file
/usr/share/mime/packages/freedesktop.org.xml.

Local transformations cannot occur unless this file is edited and the program
"update-mime-database" is run to update the gnome configuration.

Reproducible: Always
Steps to Reproduce:

Comment 1

14 years ago
That seems to be a Fedora configuration issue, probably just gnome.
This is the wrong bugzilla to report.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.