Last Comment Bug 259140 - Update default plugin
: Update default plugin
Status: VERIFIED FIXED
: fixed1.8.0.5, fixed1.8.1
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: x86 OS/2
: -- normal (vote)
: ---
Assigned To: Peter Weilbacher
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-13 11:39 PDT by Mike Kaply [:mkaply]
Modified: 2006-06-15 12:31 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
First pass (11.96 KB, patch)
2004-09-13 11:39 PDT, Mike Kaply [:mkaply]
no flags Details | Diff | Splinter Review
sync anew (23.10 KB, patch)
2006-01-07 13:55 PST, Peter Weilbacher
mozilla: review+
mozilla: superreview+
dveditz: approval‑branch‑1.8.1+
dveditz: approval1.8.0.5+
Details | Diff | Splinter Review

Description Mike Kaply [:mkaply] 2004-09-13 11:39:13 PDT
Windows default plugin has changed so we need OS/2 changes.
Comment 1 Mike Kaply [:mkaply] 2004-09-13 11:39:52 PDT
Created attachment 158768 [details] [diff] [review]
First pass

This gets things working again.
Comment 2 Steve Wendt 2005-09-29 19:03:29 PDT
Was this ever checked in?  On Seamonkey 1.0a, it appears to me that the stream
isn't being killed for the plugin data: 
  NPN_DestroyStream(pInstance, stream, NPRES_DONE);

Can't we point these to http://plugindoc.mozdev.org/OS2.html instead?
#define DEFAULT_PLUGINFINDER_URL "http://plugins.netscape.com/plug-in_finder.adp"
#define JVM_SMARTUPDATE_URL "http://plugins.netscape.com/plug-in_finder.adp"
Comment 3 Mike Kaply [:mkaply] 2005-09-30 06:24:59 PDT
Nope, I never checked this in because I thought they were going to port the new
plugin code to SeaMonkey so this wouldn't be relevant. I'll take a look at the
code again.
Comment 4 Peter Weilbacher 2006-01-07 13:55:02 PST
Created attachment 207847 [details] [diff] [review]
sync anew

Update of Mike's patch, also fixes some warnings and has two whitespace cleanups. It also changes the two URLs to point to Steve's mozdev page. Compiles on trunk.
Comment 5 Peter Weilbacher 2006-01-07 15:38:09 PST
Hmm, it just doesn't work. If I go to

http://www.dtmb.de/Rundgang/Neubau/body_schifffahrt_Aufbau01.html

and double click the jigsaw piece I am asked by the dialog to download the QT plugin from http://www.apple.com/quicktime/download/ and when I click on "Get the Plug-in" it goes to that website. With the new version the same dialog appears but it does not go to that page any more. Hmm, it seems I have to do some debugging (tomorrow or when I get the time).
Comment 6 Peter Weilbacher 2006-01-08 01:43:06 PST
OK, that's because "application.use_ns_plugin_finder" is false by default, so the patch is OK.
Comment 7 Mike Kaply [:mkaply] 2006-04-19 11:50:39 PDT
Comment on attachment 207847 [details] [diff] [review]
sync anew

r=mkaply
Comment 8 Mike Kaply [:mkaply] 2006-05-22 18:28:19 PDT
Fix checked in.
Comment 9 Steve Wendt 2006-05-22 21:12:17 PDT
Checked in on just the trunk, or branches too?
Comment 10 Mike Kaply [:mkaply] 2006-05-22 21:24:43 PDT
trunk

should I put it on the branches?
Comment 11 Steve Wendt 2006-05-22 21:30:18 PDT
Yes, please.  :)
Comment 12 Peter Weilbacher 2006-05-23 00:36:03 PDT
In principle I agree that this should go into the branches, but I think we should test the trunk version first.
Comment 13 Peter Weilbacher 2006-06-07 03:37:51 PDT
Steve, does the new version (from trunk or in my newest unofficial releases) work the way you expect it to?
Comment 14 Steve Wendt 2006-06-07 12:09:11 PDT
(In reply to comment #13)
> Steve, does the new version (from trunk or in my newest unofficial releases)
> work the way you expect it to?

Yes, the streams do stop, thanks!
Comment 15 Peter Weilbacher 2006-06-07 13:44:04 PDT
Comment on attachment 207847 [details] [diff] [review]
sync anew

OK, so we should get this on the branche(s). This is OS/2 only and was shown on the trunk to work.
Comment 16 Daniel Veditz [:dveditz] 2006-06-14 15:21:17 PDT
Comment on attachment 207847 [details] [diff] [review]
sync anew

approved for 1.8.0 branch, a=dveditz for drivers
Comment 17 Peter Weilbacher 2006-06-15 12:31:18 PDT
OK, checked into both branches.

Note You need to log in before you can comment on or make changes to this bug.