scroll bar doesn't allways work

VERIFIED DUPLICATE of bug 26658

Status

()

Core
XUL
P4
normal
VERIFIED DUPLICATE of bug 26658
19 years ago
18 years ago

People

(Reporter: thue, Assigned: Eric Vaughan)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
With M13
At apperantly random a page will seem to render normally, but when using the
scrollbar the page isn't scrolled. Also, the curser doesn't change when hovering
over a link. I marked the bug as critical as it happens pretty often.
I noticed that the page blinks gray just before the rendering is finished.

Clicking links work.
Reloading the page solves the problem.
Other open mozilla windows are not affected.(I tend to have severel windows open
at a time, maybe that influences.)

Comment 1

19 years ago
guessing trudelle.
Assignee: chofmann → trudelle

Comment 2

19 years ago
Please, one defect per bug report.  We're going to treat the comment on hovering
as an associated symptom, if you want it treated as a separate defect then open
another bug.  Changing summary to reflect one problem.

Also, this is not critical severity, that is reserved for crash, data loss or
severe leak. High frequency does not justify a high severity. Since there is a
simple workaround, I'm changing severity to 'normal', although if you weren't
seeing it a lot it would be 'minor'. 

This isn't really reproducible as written, so any further details would help
justify our spending some time on it.  for now, assigning to evaughan as p4 for
M16.
Assignee: trudelle → evaughan
Severity: critical → normal
Component: other → XP Toolkit/Widgets
Priority: P3 → P4
Summary: scroll bar and cursor markup doesn't allways work → scroll bar doesn't allways work
Target Milestone: M16
(Reporter)

Comment 3

19 years ago
It is only one bug. All the symptons appear at once and only at once. And it is
popping up _very_ regularly.

Comment 4

19 years ago
In that case,it should be possible to isolate a set of steps to reproduce.
(Reporter)

Comment 5

19 years ago
Ok - I got it reproducible at last.
-Go to www.kdevelop.org
-Open screenshot1 in a new window  (rightclick - new window)
-opdate or go to a new page in the old window
-close the old new window
-the old window should now be frozen as reported in the original bug report.

It freezes on lots of other pages, bug the above strategy doesn't work for all
pages.
(Reporter)

Comment 6

19 years ago
*sigh* it should read
"-close the new window"
as step 4
(Reporter)

Comment 7

19 years ago
Just want to add that it also freezes in some situations that don't involve
closing a window; but the freezes allways seem to happen when you are loading in
multiple windows simultaneously
(Reporter)

Comment 8

19 years ago
I have designed a minimalistic test-case.
1) go to http://hjem.get2net.dk/thue_janus_kristensen/test1.html
2) rigth-click link and choose open new window
3) push reload-button on old page (test1.html)
4) close the second window
5) old page should be frozen; try scrooling down or letting the mouse hower over
the link

Again; this is not the only situation it freezes in
(Reporter)

Comment 9

18 years ago
turning off gfx scroolbars makes the problem go away...
(Reporter)

Comment 10

18 years ago
Just want to say that it is still there in the feb 21 build, and annoying as
ever (I have to reload ~50% of all pages)

viewmaneger 2 does NOT make the problem go away

Comment 11

18 years ago

*** This bug has been marked as a duplicate of 26658 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 12

18 years ago
Marking Verified as a dup.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.