Closed Bug 259336 Opened 18 years ago Closed 18 years ago

Clicking Windows URL Shortcut on desktop opens FF & displays shortcut contents as a local text file

Categories

(Firefox :: Shell Integration, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 246078

People

(Reporter: nick, Assigned: bugs)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Apologies if already reported - found variations (eg: error msgs or multiple
windows), but couldn't locate the exact same problem as this...

Using Win XP Sp1 with FF as default browser (same problem with both FF 0.9.3 and
also new 1.0 RC version). 

First uninstalled old FF & manually deleted
\Documents&Settings\ApplicationData\Mozilla\Firefox THEN installed 1.0 RC, so it
should be a clean install. 

Problem description: Double-click a desktop shortcut to open a site using
default browser (FF); get no errors and only one page opens in FF - *BUT*
instead of actually opening the site that is referenced by the url, it opens the
shortcut file as a local text file. 

Result: The url field in the toolbat contains the address of the local shortcut
file, eg: "file:///C:/Documents%20and%20Settings/Nick/Desktop/Test.url" and the
page contents displayed are the contents of the shortcut, eg: 

[InternetShortcut]
URL=http://www.cnn.com/
Modified=8073D6D57C9AC40179

BTW, I've read the other similar bug reports & tried screwing around with
"C:\Program Files\Mozilla Firefox\firefox.exe" -url "%1" in the Windows File
Types associations, as well as checking & un-checking "Use DDE". No luck.

Thanks for your time,
Nick

Reproducible: Always
Steps to Reproduce:
1. Uninstall old FF
2. Delete old profiles, etc
3. Install new FF, check it is the default browser.
4. In Windows right click desktop, select New / Shortcut. Type eg:
"http://www.cnn.com" as location, Type "Test" as name of shortcut.
5. Double click the shortcut to launch page in FF.

Actual Results:  
Instead of opening eg: www.cnn.com, it opens the desktop shortcut as a local
file and displays the destination url as text. Browser displays:

[InternetShortcut]
URL=http://www.cnn.com/
Modified=8073D6D57C9AC40179

Expected Results:  
Should open the actual destination site not the desktop shortcut itself.
This is probably the same general issue as bug 246078, but you have your
registry keys set differently somehow.  If 1.0PR thinks it's still default (from
an old install), it might not rewrite the registry keys with that bug's fix.

Try this:
Internet Exloperer -> Internet Options.
Programs -> Reset Web Settings -> Ok.

Then load up Firefox and reset that as the default.  Please make sure you're not
getting remnants of the old registry keys if you consider reopening this bug.

*** This bug has been marked as a duplicate of 246078 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
That workaround fixed it! Fantastic - thanks!
Nick
You need to log in before you can comment on or make changes to this bug.