Live bookmarks feed discovery problems

RESOLVED DUPLICATE of bug 257247

Status

()

defect
RESOLVED DUPLICATE of bug 257247
15 years ago
13 years ago

People

(Reporter: philor, Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

()

Reporter

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Live bookmark discovery fails several tests related to parsing the type
attribute on link elements: we should be doing a case-insensitive match,
trimming leading and trailing whitespace in the attribute value, and decoding
numeric character references before matching.

Reproducible: Always
Steps to Reproduce:
All of these test cases fail:

http://diveintomark.org/tests/client/autodiscovery/html4-014.html
http://diveintomark.org/tests/client/autodiscovery/html4-015.html
http://diveintomark.org/tests/client/autodiscovery/html4-016.html
http://diveintomark.org/tests/client/autodiscovery/html4-017.html
http://diveintomark.org/tests/client/autodiscovery/html4-018.html
http://diveintomark.org/tests/client/autodiscovery/html4-038.html
http://diveintomark.org/tests/client/autodiscovery/html4-039.html
http://diveintomark.org/tests/client/autodiscovery/html4-040.html
http://diveintomark.org/tests/client/autodiscovery/html4-055.html
Reporter

Comment 1

15 years ago
Sorry, ignore the "decoding numeric character references" - I was
misinterpreting the failure on test 55, where the decoded reference makes the
type applIcation/atom+xml, and we fail from case-sensitivity.

*** This bug has been marked as a duplicate of 257247 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.