The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member "SelectLocaleForProfile"

RESOLVED DUPLICATE of bug 258831

Status

RESOLVED DUPLICATE of bug 258831
14 years ago
14 years ago

People

(Reporter: nickb, Unassigned)

Tracking

Other Branch
SGI
IRIX

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
Building Firefox 1.0PR or Thunderbird 0.8 (I haven't tried mozilla trunk yet), I
get this compile error:

This using MipsPro 7.3.1.3m

CC -o nsProfile.o -c -DOSTYPE=\"IRIX6\" -DOSARCH=\"IRIX\"
-I./../dirserviceprovider/src -I../../dist/include/xpcom
-I../../dist/include/xpcom_obsolete -I../../dist/include/string
-I../../dist/include/content -I../../dist/include/docshell
-I../../dist/include/webbrwsr -I../../dist/include/dom -I../../dist/include/js
-I../../dist/include/xpconnect -I../../dist/include/widget
-I../../dist/include/necko -I../../dist/include/uriloader
-I../../dist/include/intl -I../../dist/include/pref
-I../../dist/include/prefmigr -I../../dist/include/appshell
-I../../dist/include/uconv -I../../dist/include/windowwatcher
-I../../dist/include/profdirserviceprovider -I../../dist/include/profile
-I../../dist/include -I/home/nickb/thunderbird/mozilla/dist/include/nspr       
-KPIC   -LANG:exceptions=OFF -woff 3262 -G 4 -n32  -DNDEBUG -DTRIMMED -O3  
-DMOZILLA_VERSION=\"1.7.3\" -DIRIX=1 -DNSCAP_DISABLE_DEBUG_PTR_TYPES=1
-DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_ST_BLKSIZE=1 -DHAVE_SIGINFO_T=1
-DHAVE_INT16_T=1 -DHAVE_INT32_T=1 -DHAVE_INT64_T=1 -DHAVE_UINT=1 -DHAVE_UINT_T=1
-DHAVE_UINT16_T=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1
-DHAVE_UNISTD_H=1 -DHAVE_NL_TYPES_H=1 -DHAVE_MALLOC_H=1 -DHAVE_X11_XKBLIB_H=1
-DHAVE_SYS_STATVFS_H=1 -DHAVE_SYS_STATFS_H=1 -DHAVE_SYS_CDEFS_H=1 -DHAVE_LIBM=1
-DHAVE_LIBDL=1 -DHAVE_LIBSOCKET=1 -DFUNCPROTO=15 -DHAVE_XSHM=1 -DHAVE_RANDOM=1
-DHAVE_STRERROR=1 -DHAVE_LCHOWN=1 -DHAVE_FCHMOD=1 -DHAVE_SNPRINTF=1
-DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DHAVE_FLOCKFILE=1 -DHAVE_LOCALTIME_R=1
-DHAVE_STRTOK_R=1 -DHAVE_LANGINFO_CODESET=1 -DHAVE_I18N_LC_MESSAGES=1
-DMOZ_DEFAULT_TOOLKIT=\"gtk\" -DMOZ_WIDGET_GTK=1 -DMOZ_ENABLE_XREMOTE=1
-DMOZ_X11=1 -DMOZ_THUNDERBIRD=1 -DMOZ_STATIC_MAIL_BUILD=1 -DMOZ_XUL_APP=1
-DMOZ_APP_NAME=\"thunderbird\" -DMOZ_ENABLE_COREXFONTS=1
-DMOZ_EXTRA_X11CONVERTERS=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DACCESSIBILITY=1
-DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DMOZ_LOGGING=1 -DMOZ_USER_DIR=\".mozilla\"
-DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_DLL_SUFFIX=\".so\" -DXP_UNIX=1
-DUNIX_ASYNC_DNS=1 -DJS_THREADSAFE=1 -DNS_PRINT_PREVIEW=1 -DNS_PRINTING=1
-DMOZILLA_LOCALE_VERSION=\"1.7\" -DMOZILLA_REGION_VERSION=\"1.7\"
-DMOZILLA_SKIN_VERSION=\"1.5\"  -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT nsProfile.cpp
cc-1132 CC: ERROR File = nsProfile.cpp, Line = 414
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member
          "SelectLocaleForProfile".

          rv = chromeRegistry->SelectLocaleForProfile(mUILocaleName,
                               ^

cc-1132 CC: ERROR File = nsProfile.cpp, Line = 423
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member
          "SelectLocaleForProfile".

          rv = chromeRegistry->SelectLocaleForProfile(mContentLocaleName,
                               ^

cc-1132 CC: ERROR File = nsProfile.cpp, Line = 1724
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member
          "SelectLocaleForProfile".

              rv = chromeRegistry->SelectLocaleForProfile(uiLocale, 
                                   ^

cc-1132 CC: ERROR File = nsProfile.cpp, Line = 1736
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member "GetSelectedSkin"
          .

          rv =
packageRegistry->GetSelectedSkin(NS_LITERAL_CSTRING("global"),currentSkinName);
                                ^

cc-1132 CC: ERROR File = nsProfile.cpp, Line = 1738
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member
          "SelectSkinForProfile".

              rv = chromeRegistry->SelectSkinForProfile(currentSkinName,
                                   ^

cc-1132 CC: ERROR File = nsProfile.cpp, Line = 1760
  The class "nsDerivedSafe<nsIXULChromeRegistry>" has no member
          "SelectLocaleForProfile".

              rv = chromeRegistry->SelectLocaleForProfile(contentLocale, 
                                   ^

6 errors detected in the compilation of "nsProfile.cpp".
gmake[3]: *** [nsProfile.o] Error 2
gmake[3]: Leaving directory `/home/nickb/thunderbird/mozilla/profile/src'

Comment 1

14 years ago
I get basically the same problem on OpenBSD 3.5, when compiling firefox 1.0PR
with either GCC 2.95.3 or 3.4.2:

c++ -o nsProfile.o -c -DOSTYPE=\"OpenBSD3\" -DOSARCH=\"OpenBSD\"
-I./../dirserviceprovider/src -I../../dist/include/xpcom
-I../../dist/include/xpcom_obsolete -I../../dist/include/string
-I../../dist/include/content -I../../dist/include/docshell
-I../../dist/include/webbrwsr -I../../dist/include/dom -I../../dist/include/js
-I../../dist/include/xpconnect -I../../dist/include/widget
-I../../dist/include/necko -I../../dist/include/uriloader
-I../../dist/include/intl -I../../dist/include/pref
-I../../dist/include/prefmigr -I../../dist/include/appshell
-I../../dist/include/uconv -I../../dist/include/windowwatcher
-I../../dist/include/profdirserviceprovider -I../../dist/include/profile
-I../../dist/include -I/disk/or/dm/moz/mozilla/dist/include/nspr 
-I/usr/local/include  -I/usr/include -I/usr/X11R6/include   -fPIC 
-I/usr/X11R6/include -fno-rtti -fno-exceptions -Wall -Wconversion
-Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy
-Wno-non-virtual-dtor -Wno-long-long -fshort-wchar -pipe  -DDEBUG -D_DEBUG
-DDEBUG_dm -DTRACING -g -Os  -I/usr/X11R6/include -DMOZILLA_CLIENT -include
../../mozilla-config.h -Wp,-MD,.deps/nsProfile.pp nsProfile.cpp
nsProfile.cpp: In member function `virtual nsresult
nsProfile::StartupWithArgs(nsICmdLineService*, PRBool)':
nsProfile.cpp:414: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'SelectLocaleForProfile'
nsProfile.cpp:423: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'SelectLocaleForProfile'
nsProfile.cpp: In member function `virtual nsresult
nsProfile::CreateNewProfileWithLocales(const PRUnichar*, const PRUnichar*, const
PRUnichar*, const PRUnichar*, PRBool)':
nsProfile.cpp:1724: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'SelectLocaleForProfile'
nsProfile.cpp:1736: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'GetSelectedSkin'
nsProfile.cpp:1738: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'SelectSkinForProfile'
nsProfile.cpp:1760: error: 'class nsDerivedSafe<nsIXULChromeRegistry>' has no
member named 'SelectLocaleForProfile'
gmake[4]: *** [nsProfile.o] Error 1
gmake[4]: Leaving directory `/disk/or/dm/moz/mozilla/profile/src'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/disk/or/dm/moz/mozilla/profile'
gmake[2]: *** [tier_9] Error 2
gmake[2]: Leaving directory `/disk/or/dm/moz/mozilla'
gmake[1]: *** [default] Error 2
gmake[1]: Leaving directory `/disk/or/dm/moz/mozilla'
gmake: *** [build] Error 2

For what it's worth, the following is my .mozconfig, which worked fine with
firefox 0.9.  Maybe I have some old bad options in there or something.

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1
PKG_CONFIG_PATH=/usr/X11R6/lib/pkgconfig:/usr/local/lib/pkgconfig
export PKG_CONFIG_PATH
ac_add_options --enable-xft
ac_add_options --disable-logging
ac_add_options --with-pthreads
ac_add_options --with-system-jpeg=/usr/local
ac_add_options --with-system-zlib=/usr
ac_add_options --with-system-png=/usr/local
ac_add_options --disable-mailnews
ac_add_options --disable-ldap
ac_add_options --enable-crypto
ac_add_options --disable-composer
ac_add_options
--enable-extensions=cookie,xml-rpc,xmlextras,p3p,pref,transformiix,universalchardet,typeaheadfind,webservices,inspector,gnomevfs,negotiateauth
ac_add_options --disable-installer
ac_add_options --disable-tests
ac_add_options --enable-optimize=-Os
ac_add_options --disable-pedantic
(Reporter)

Comment 2

14 years ago
My mozconfig:
# sh
# Build configuration script
#
# See http://www.mozilla.org/build/unix.html for build instructions.
#
#
# Typical Win32 build options for 'configure' (same as command-line options)

ac_add_options --host=mips-sgi-irix6.5
ac_add_options --target=mips-sgi-irix6.5


ac_add_options --enable-crypto
ac_add_options --disable-mathml
ac_add_options --disable-installer
ac_add_options --disable-activex
ac_add_options --disable-activex-scripting
ac_add_options --disable-tests
ac_add_options --enable-oji
ac_add_options --disable-necko-disk-cache

# Note: remove enable-optmize and disable debug if you want a debug build
ac_add_options --enable-optimize=-O3
ac_add_options --disable-debug
ac_add_options --enable-strip
ac_add_options --enable-strip-libs

ac_add_options --disable-profilesharing
#ac_add_options
--enable-extensions=cookie,wallet,content-packs,help,p3p,pref,transformiix,venkman,inspector,irc,universalchardet,typeaheadfind,webservices,datetime,xmlextras
ac_add_options --enable-extensions=all
#ac_add_options
--enable-necko-protocols=about,data,gopher,keyword,http,ftp,file,jar,viewsource,res,data
ac_add_options --enable-necko-protocols=all,telnet

# Note: Only include icon for mac, windows and os2
ac_add_options --enable-image-decoders=png,gif,jpeg,bmp,xbm

# Disable mailnews...
ac_add_options --disable-mailnews

export MOZ_PHOENIX=1
mk_add_options MOZ_PHOENIX=1

# Note: When building bits to distribute to other uses and not just a debug
build, I also suggest
# adding these flags. 

export BUILD_OFFICIAL=1
export MOZILLA_OFFICIAL=1
mk_add_options BUILD_OFFICIAL=1
mk_add_options MOZILLA_OFFICIAL=1 

I wont bother posting my thunderbird config... but its similar (but different
obviously!).

Comment 3

14 years ago
I get the same error compiling Firefox 1.0PR on Solaris

Comment 4

14 years ago
This is a duplicate of bug 258831

The bottom line is that you need "--enable-single-profile", and you ought to
be including the standard "browser/config/mozconfig"
(Reporter)

Comment 5

14 years ago
Dupe. 

*** This bug has been marked as a duplicate of 258831 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.