Spaces in filename to be downloaded cause the download to be misnamed

VERIFIED DUPLICATE of bug 221028

Status

()

VERIFIED DUPLICATE of bug 221028
14 years ago
10 years ago

People

(Reporter: pmaccabe, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040626 Firefox/0.9.1

When downloading any of the files from this site the filenames are corrupted by
the download manager by being cut off at the first space. (The site has a free
registration, and if you through it and then click the link in the activation
e-mail it takes you to where you can download free mp3s) The names of most of
these mp3s contain spaces. "Ch 01 Jarom (Book of Mormon).mp3" becomes Ch for
example. Many of the files are compressed zip files containing several mp3s
these are all downloaded with incorrect names as well. In Internet Explorer the
downloads proceed fine and name the files correctly.

Reproducible: Always
Steps to Reproduce:
1. Visit LDSAudio.com
2. Go through free registration, give a junk mail e-mail address
3. Go to junk mail account and follow activation link, log into site
4. Try downloading any of the free Book of Mormon files.

Actual Results:  
It downloads the file just fine but the name including the extension is
truncated at the first space in the filename, this may be because the file is
streamed somehow? 

Expected Results:  
The software should have created filenames with spaces, etc and the appropriate
extensions

Comment 1

14 years ago
Looks like Bug 221028.

Please create an HTTP log as described at
http://www.mozilla.org/projects/netlib/http/http-debugging.html and attach it to
this bug.

Comment 2

14 years ago
It's probably a dupe. All of these ones about spaces in filenames are.

*** This bug has been marked as a duplicate of 221028 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.