ftp.m.o tarballs require sending lots of files to server (CygWin)

RESOLVED WORKSFORME

Status

Firefox Build System
General
--
major
RESOLVED WORKSFORME
14 years ago
2 months ago

People

(Reporter: WeirdAl, Unassigned)

Tracking

1.9.0 Branch
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
Apparently, the mozilla-source.tar.gz files, once untarred, still do not have
good CVS repository information.  We end up sending tons and tons of files to
the server anyway.

Steps to reproduce:

(1) In .mozconfig, include the following:

mk_add_options MOZ_CVS_FLAGS="-t -q -z 9"
(-z 3 if you're on broadband)

The -t option forces cvs to report everything it's doing, and also logs these
details.

(2) Get a brand-spanking-new tarball from ftp.mozilla.org.

(3) Untar the whole thing, and move .mozconfig into the mozilla directory.

(4) Follow checkout instructions from mozilla.org (URL field).

(5) When it ends, open cvsco.log, and compare that against
http://lxr.mozilla.org/seamonkey .


Expected results:  A short cvsco.log file, with not too many "Sending file"
statements.

Actual results: Lots of files get sent to the server, many of them apparently
with LXR dates much older than the tarball itself.
(gbint.h seems to be a good example.)

Quoting from the URL field's page:

"In order to use cvs under Windows, you must have unpacked the source from the
`tar' file, not from a `zip'. The zip file format does not store dates with
enough accuracy for cvs, so updating source unpacked from a zip with cvs takes a
really long time because the cvs client must send most files to the server to
determine if they have changed."

In other words, sending files to CVS during checkout is clearly bad.

jesus_X has provided independent confirmation of this bug.
Product: Browser → Seamonkey

Updated

9 years ago
Component: Build Config → Build Config
Product: SeaMonkey → Core
Whiteboard: CLOSEME?
Version: Trunk → 1.9.0 Branch
CVS is so passe.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Whiteboard: CLOSEME?

Updated

2 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.