download manager ended downloading when no free disk space left without info

VERIFIED DUPLICATE of bug 65770

Status

()

Toolkit
Downloads API
VERIFIED DUPLICATE of bug 65770
14 years ago
10 years ago

People

(Reporter: Marcin, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

At first i apologize for my English...
I set downloading and i go sleep, but i dont see that i dont have needed disk
space. So when i wake up and look into download manager i see "Done" but files
havent got accurate file size. I look into "propeties" of files and they ended
same time. So in my this is bug. At first if file size is know. DM should check
availbe disk space, at next if DM will not have space when it download it should
"Pause" and show any info not "Done!" 

BTW. I think that tranfer summary should be in DM

Reproducible: Always
Steps to Reproduce:
1.make no space in your disk :)
2.try to download file bigger than free space on Your disk
3.see "Done" and try to execute incomplete "done" files...

Actual Results:  
no info about no space left, my new files have wrong file size, and i must
download them again

Expected Results:  
1. check availbe free disk space
2. when "no space left" it should pause downloading (If i free some disk space,
i want to continue downloading)
3. it should show info with action to choose
(Reporter)

Comment 1

14 years ago
it will be wonderful if also i could resume not ended download (in example i
want to redownload my broken files, and i want to end download from position
when its stopped)
Summary: download manager ended downloading when no free disk space left → download manager ended downloading when no free disk space left without info

Comment 2

14 years ago
*** Bug 259756 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago

*** This bug has been marked as a duplicate of 65770 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.