Closed Bug 259826 Opened 18 years ago Closed 18 years ago

After upgrading to Firefox 1.0PR from 0.93, NTLM proxy dialog won't stop popping up

Categories

(Toolkit :: Password Manager, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 256949

People

(Reporter: aziegenfus, Assigned: bryner)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

I've read the other bugs about the proxy dialog continually popping up but I've
never had this problem before and I'm pretty sure nothing changed on the proxy
end. Right before I upgraded to Firefox 1.0PR everything was fine. I've tried
removing the password information and restarting Firefox but I still get the
problem. 

Reproducible: Always
Steps to Reproduce:
1. Open a web site
2. 
3.

Actual Results:  
NTLM dialog pops up asking for password. For some sites I get the dialog
multiple times (maybe for images that load from other sites?)

Expected Results:  
Not pop up the dialog after the first time.
The NTLM dialog popped up at least 5 times while this log was running.
I just confirmed that when running an earlier version of Firefox (Firebird 0.7)
against the same proxy server, I don't have this problem.
Ok I've found that if I set this new preference
network-automatic-ntlm-auth.allow-proxies to FALSE then I no longer get this
problem. Am I missing something here? I thought that preference should meant I
*never* get the popup. 
It looks like this has to do with how bug 231529 was addressed. Because I use
different credentials for proxy connections than how I am logged in, I keep
getting the popups. If I turn the allow proxy setting off then I am fine,
although I still have to enter the credentials on firefox startup.

*** This bug has been marked as a duplicate of 256949 ***
Status: UNCONFIRMED → RESOLVED
Closed: 18 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.