Firefox must be restarted when a theme is switched to

RESOLVED DUPLICATE of bug 226791

Status

()

RESOLVED DUPLICATE of bug 226791
14 years ago
11 years ago

People

(Reporter: maxozilla, Assigned: bugs)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

When choosing another theme to be used, FireFox must be restarted. This was not
the case in previous versions of FireFox, therefore it should be possible to
avoid this. For the user to have to close all of their browser windows every
time they change their theme or install a new extension is irritating and can be
avoided.

Reproducible: Always
Steps to Reproduce:
1. install a new theme
2. try clicking on 'use theme' in themes manager. 

Actual Results:  
It'll tell you to restart firefox

Expected Results:  
Like previous versions of FireFox, it should have switched to this theme
immediately.

Comment 1

14 years ago
This is on purpose, because of more serious bugs that were occurring with
dynamic switching without restarting.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

14 years ago
Shouldn't this bug be kept open because these more serious bugs should be fixed.
Having to restart Firefox every single time you install a new extension or theme
is just out of date with FireFox's new image as a modern and capable web browser.
(Reporter)

Updated

14 years ago
Status: RESOLVED → REOPENED
Resolution: INVALID → ---

Comment 3

14 years ago
Dynamic Theme switching is turned off for Firefox 1.0.  There is a goal to bring
it back, but not until the bugs for it are fixed.  The more serious bugs are
being worked on in the dupe and it's dependencies.

*** This bug has been marked as a duplicate of 226791 ***
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.