If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

SELECT field border doesn't redraw correctly on focus change

VERIFIED DUPLICATE of bug 25258

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED DUPLICATE of bug 25258
18 years ago
18 years ago

People

(Reporter: sottek, Assigned: Pierre Saslawsky)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
Most pages that use XPtoolkit form widgets have this problem. I'll
include a short example here. If I click a widget i.e. multi select
the borders are usually redrawn as dashed lines (on purpose?) if I then
click on another widget the borders are not redrawn. In order to make
the borders draw again correctly I have to give focus to another widget
then do a mouseover on the corrupted widget. Text boxes are also drawn
incorrectly but with inconsistent behavior.

RH 6.1, XFree86 3.3.5, M13
in the example click the multi select it will be corrupt, click the test box
then mouse over on the multi select, it will clean itself up.

<html><head><title>Testcase for bug 25617</title></head>
<body BGCOLOR="#ffffff">

<form method="GET" action="/blah">
<input name="qt">
<select name="tg"><option value="1" selected>In News
<option value="2">All CNET
</select>
</form>

</body>
</html>
(Reporter)

Comment 1

18 years ago
Created attachment 4777 [details]
Example attached

Comment 2

18 years ago
This is an HTML forms bug.  Change summary and reassign to karnaze.
Assignee: trudelle → karnaze
Component: XP Toolkit/Widgets → HTML Form Controls
Summary: XPToolkit doesn't redraw correctly on focus entry/exit → SELECT field border doesn't redraw correctly on focus change

Comment 3

18 years ago
Reassigning to Rod.
Assignee: karnaze → rods

Comment 4

18 years ago
yet another focus bug.....
Assignee: rods → saari

Comment 5

18 years ago
NOT yet another focus bug. Focus is fine in most cases, go put some handlers on 
things to convince yourself of that.

If it was a focus problem, mousing over would do nothing to fix it and make 
things draw correctly.

I think this is actually a CSS issue that blur is not trigging a reflow/repaint 
when it should.
Assignee: saari → pierre
(Assignee)

Comment 6

18 years ago


*** This bug has been marked as a duplicate of 25258 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 7

18 years ago
Sorry for the spam, changing QA contact.
QA Contact: paulmac → ckritzer

Comment 8

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.