Persona is no longer an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 26026 - embedded stylesheet in XHTML 1.0 document is not recognized.
: embedded stylesheet in XHTML 1.0 document is not recognized.
Status: VERIFIED DUPLICATE of bug 36790
: helpwanted, xhtml
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: x86 Windows 95
: P3 normal with 3 votes (vote)
: Future
Assigned To: Nisheeth Ranjan
: Chris Petersen
: Jet Villegas (:jet)
Depends on: 21771
  Show dependency treegraph
Reported: 2000-02-01 00:04 PST by Ryosuke_Nanba
Modified: 2002-06-08 18:27 PDT (History)
5 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Ryosuke_Nanba 2000-02-01 00:04:47 PST
XHTML 1.0 document which has embeded stylesheet in 'style' element 
is not rendered correctly.
Comment 1 troy 2000-02-01 08:21:16 PST
Nisheeth, XHTML issue
Comment 2 Nisheeth Ranjan 2000-02-08 14:32:27 PST
Moving these XHTML bugs to M17...
Comment 3 Nisheeth Ranjan 2000-04-04 14:33:15 PDT
Moving bugs out by one milestone...
Comment 4 Nisheeth Ranjan 2000-04-12 22:42:15 PDT
We don't currently support inline style attributes or style tags inside XML 
documents.  Marking M19...
Comment 5 Nisheeth Ranjan 2000-06-08 23:24:11 PDT
This bug has been marked "future" because the original netscape engineer working 
on this is over-burdened. If you feel this is an
error, that you or another known resource will be working on this bug,or if it 
blocks your work in some way -- please attach your
concern to the bug for reconsideration. 
Comment 6 Karl Ove Hufthammer 2000-06-09 04:42:23 PDT
"Future"? Not supporting the 'style' element in XHTML documents is a ***very*** serious bug which *must* be fixed, IMNSHO.
Comment 7 Nisheeth Ranjan 2000-06-14 00:47:15 PDT
Karl, can you provide some reasoning behind your worry?  Wouldn't it be possible 
to workaround the absence of the style element by using an external stylesheet?

One of the reasons to mark bugs future was to find out what developers care 
about.  Please feel free to frankly say what you want.  We are listening and 
will work with you to do the right thing.  Thanks for your last comment.
Comment 8 Karl Ove Hufthammer 2000-06-14 09:31:17 PDT
Of course it is possible to use a work-around, to *only* use linked style sheets in XHTML documents. But this makes life much harder for for authors. It's much easier to use the 'style' element for a one-off style rule, than it is to create a separate linked style sheet. Partial HTML (and CSS) support has been a terrible thing, since one could never know what would work in which browsers. Partial XHTML is even worse, since XHTML is a new standard, and we really *don't* need browser bugs on this.

If Mozilla doesn't support the 'style' element, its XHTML support is really lousy. And people can *never* start using it again, because they want their pages to backwards-compatible with older browsers, such as Mozilla 5.0.
Comment 9 Nisheeth Ranjan 2000-06-20 17:36:23 PDT
The right way of fixing this bug is to factor code between the XML and HTML 
content sinks.  Right now, the style tag is processed on the HTML content sink, 
but not on the XML content sink.  The hacky solution is to copy the code 
that processes style tags from the HTML content sink over to the XML content 
sink.  The decision to invest time in fixing this bug depends on whether 
Netscape has committed to supporting XHTML completely in Netscape 6.0.

CCing Eric Krock, our group product manager, to initiate a discussion about 
this.  Eric, should this bug be fixed pre or post 6.0?
Comment 10 bertilow 2000-07-15 05:28:47 PDT
Are you really seriously considering launching Mozilla with less support for
XHTML than MSIE4/5 and Netscape 4? XHTML is the current HTML standard (actually
several months old by now). A new browser without full support for XHTML would
be a joke. Either reconsider this now, or dump the whole Mozilla project.
/Bertilo Wennergren
Comment 11 ekrock's old account (dead) 2000-07-17 13:32:35 PDT
Like everyone else, I would like to see XHTML support in the first releases of 
Mozilla/Gecko/N6, and I would like that support to be as good as possible. 
*However*, we need to remember that there has *never* been a commitment by 
Netscape to support XHTML at all in the first release, let alone fully.

I am marking this helpwanted. We would welcome it if a member of the mozilla 
community would step forward to contribute a patch for this issue. If no member 
of the open source community is willing to do this work, then Netscape will try 
to get to this issue as its resources and schedules allow, and currently 
Netscape is quite overburdened.

Separation of content from formatting is a good thing for its own sake. 
Therefore, I don't think it's the end of the world if Netscape manages to exceed 
its product goals for the first release and get in basic support for XHTML in 
the first release, with the proviso that style sheets must be external rather 
than inline.

Thanks to everyone for your help on compliance analysis and bug reporting!
Comment 12 bertilow 2000-08-12 14:46:38 PDT
I just tested this in Mozilla/5.0 (Windows; U; Win98; en-US; m18) Gecko/20000811
and embedded style commands seem to work now. Great! Actually _all_ of the XHTML
problems that have bothered me in Mozilla seem to suddenly have vanished. What 
has happened?
Comment 13 Antti Näyhä 2000-10-03 01:40:54 PDT
The problem still occurs for me when viewing the test case at with build 2000-10-01-08 
(WinNT4). I guess there's been a temporary glitch which hid the 
problem in your build.
Comment 14 Heikki Toivonen (remove -bugzilla when emailing directly) 2001-01-16 13:25:22 PST
This is a dupe. Even though this is older, I am marking this as a dupe of the
other one because I have already duped one other bug to it.

*** This bug has been marked as a duplicate of 36790 ***
Comment 15 Matt Perry 2002-06-08 18:27:46 PDT

Note You need to log in before you can comment on or make changes to this bug.