Mail Client Text Editing/Saving problem changing normal text into quotation

RESOLVED DUPLICATE of bug 194382

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 194382
14 years ago
13 years ago

People

(Reporter: J. HENKES, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6) Gecko/20040117
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.6) Gecko/20040117

After 'Saving' or 'Saving As' a composed mail text, or when using the 'Send-' or
'Send Later'-option which saves to the 'Sent' or 'Unsent' folder, all mail text
lines and paragraphes beginning with the Word "From" (Capital F!, without the
quotes) followed by at least some other text gets changed as if it were a
quotation of text.

In the middle of normal text some lines or even whole blocks starting with
"From" show up as quotation (arrows in front of, etc.) and also behave as such
(no line wrapping as does the normal new text, etc.).

This problem exists at least since the Netscape/2 4.xx mail client.


Reproducible: Always
Steps to Reproduce:
1.Compose a (plain text) mail message containing for instance the line "From
France with Love" (no quotes)
2.Send (later) or save the message.
3.Look at it in the folder where it got copied to.

Actual Results:  
The lines containing the "From" word followed by more text show up as quotation.

Expected Results:  
It should have shown these lines or paragraphes as normal (un-quoted) text just
like the other lines not starting with "From".

The browser used at this time has the default theme, and has only few extensions
installed.

Linky, Dutch language scheme (not active in this profile), middle mouse button
scroll.

The bug has existed for many years, thought it about time to report the problem. :-)

about:buildconfig

Build platform
target
i386-pc-os2-emx

Build tools
Compiler 	Version 	Compiler flags
gcc 	gcc version 3.2.2 (Innotek Build 2003-10-06 19:38) 	-Wall -W -Wno-unused
-Wpointer-arith -Wcast-align -Wno-long-long -pedantic -Zomf -pipe
g++ 	gcc version 3.2.2 (Innotek Build 2003-10-06 19:38) 	-fno-rtti
-fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align
-Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-long-long -pedantic
-Zomf -pipe

Configure arguments
--disable-debug --enable-optimize --enable-crypto --disable-profilesharing
**************************************************************************

Thanks for looking into this and more thanks for providing us with such a
marvellous multi-purpose product!

Best regards,
Jan Henkes
..._._
(Reporter)

Comment 2

14 years ago
(In reply to comment #1)
> By design e.g. http://slashdot.org/articles/01/04/25/1247249.shtml
> epyhda?

Comment 3

14 years ago
Well, I am not suggesting that Slashdot is authoritative, but it does
cover the news, and it may be news to people who come to this bug
that most (if not all) Mail Agents quote (escape) the word From appearing
at the start of a line.

The article gives a lot of other background information, links to
RFC's and various comments on the topic at hand, some of which are 
(like the OP) critical of this practice and the also the fact that
it is non-obvious.

This was the best I could find quickly, given that Google cannot be
expected to come up with much on the word 'From'.

Now, what about the word 'epyhda'.

Comment 4

14 years ago
I am not sure which one is the correct on to dupe this to, it's either  bug
121947 or bug 194382. Because the latter explains about the shortcomings of the
mbox format I use that...

*** This bug has been marked as a duplicate of 194382 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.