Find (ctrl-F & /) is broken in Linux on PR1

RESOLVED INVALID

Status

()

RESOLVED INVALID
14 years ago
11 years ago

People

(Reporter: monty, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040916 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040916 Firefox/0.10

ctrl-F will find only the first occurance of a word in a page. Ctrl-G does not
find subsequent words. In the new toolbar at the bottom of the browser, only the
Highlight button works (but it works great and is really cool!). Find seems to
work great in Windows.

Reproducible: Always
Steps to Reproduce:
1.Type Ctrl-F, enter a common word
2.Type Ctrl-G (nothing happens)
3.Press Find Next & Find Previous buttons (again, nothing)

Actual Results:  
Finds only first word

Expected Results:  
Ctrl-g should find subsequent instances of that word

Running Gentoo Linux, built from source. Built with CFLAGS="-march=pentium4 -O3
-pipe -fomit-frame-pointer -fprefetch-loop-arrays -fforce-addr -falign-functions=4".

Reproducible on vanilla firefox downloaded from mozilla.org

Comment 1

14 years ago
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040916 Firefox/0.10

I am seeing the same problem here. Find works for me on Windows XP and Mac OS X,
but not linux.
iirc, there's a gentoo bug on this being broken in the gentoo source.  I might
be wrong.

Can you replicate this on a mozilla.org binary?
(Reporter)

Comment 3

14 years ago
(In reply to comment #2)
> iirc, there's a gentoo bug on this being broken in the gentoo source.  I might
> be wrong.
> 
> Can you replicate this on a mozilla.org binary?

I just downloaded this and tried it w/ a mozilla binary, and it does not display
the problem. I believe you're right that it is a gentoo problem.

Comment 4

14 years ago
I am not using Gentoo. I installed from freshrpms. I will install the
mozilla.org binary and try again.

Comment 5

14 years ago
Using the firefox installer I reinstalled and it works now.

Comment 6

14 years ago
(In reply to comment #3)
> I just downloaded this and tried it w/ a mozilla binary, and it does not display
> the problem. I believe you're right that it is a gentoo problem.

This bugs appears also on Mandrake. The strange thing is that I've two very
similar computers (with the same binaries) and the "search" works only on one of
them, the other one have this bug. It might come from the preferences but I've
done a diff and couldn't find anything suspect :-( 

Comment 7

14 years ago
Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040923 Firefox/0.10
Built on Redhat7.3.
Unable to find, only highlight. (The only functional item in new toolbar is
"highlight").
Old find (in ver0.9.3) worked correctly in same build environment.
If you build yourself, please attach the output of about:buildconfig as a text
file.  I think if you don't build typeaheadfind it'll hork.

Comment 9

14 years ago
Created attachment 159890 [details]
about:buildconfig from build on Redhat 7.3

Comment 10

14 years ago
In the Javascript Console I'm finding the following related error:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE) [nsIJSCID.createInstance]" 
nsresult: "0x80570015 (NS_ERROR_XPC_CI_RETURNED_FAILURE)"  location: "JS frame
:: chrome://global/content/bindings/browser.xml :: get_fastFind :: line 242" 
data: no]

This error is repeated everytime the find should be updated (ie when switching
to another frame, when changing the find criteria, when "find next|previous" are
clicked.
(Reporter)

Comment 11

14 years ago
Created attachment 160046 [details]
Build environments, mozilla binary & gentoo (broken find)

The top about:buildconfig is the mozilla binary. The next one is from gentoo
which has the broken find.
(Reporter)

Comment 12

14 years ago
Funny thing I noticed about the two buildconfigs is that the mozilla binary does
not add 'typeaheadfind' as one of its extensions. I'll try rebuilding without
typeaheadfind in gentoo and see if that might be the problem.

Comment 13

14 years ago
Yes, it seems to be related to the fact that some Linux Distributions still
enable the extension typeaheadfind. This seems to break the find-functionality
that is now included in Firefox.

For Gentoo there is already a bug reported at
http://bugs.gentoo.org/show_bug.cgi?id=64196 and it contains a patch that fixes
this.

Comment 14

14 years ago
Created attachment 160254 [details]
about:buildconfig from (working) build on Redhat 7.3

Removing typeaheadfind from the --enable-extensions in my .mozconfig, followed
by a clean build (gmake -f client.mk clean && gmake -f client.mk), resulted in
a working find.
ah, right, typeaheadfind shouldn't be built, since we use a variant on that as a
core component now.

resolving invalid, since the default .mozconfig is what people are in theory
supposed to build with.

bsmedberg is working on better sanity checking for configure under another bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.