Closed Bug 260429 Opened 17 years ago Closed 17 years ago

JavaScript status bar changes incorrectly affect all tabs

Categories

(Firefox :: Tabbed Browser, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 104532

People

(Reporter: public, Assigned: bugs)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

When JavaScript code writes out changes to the status bar, such as scrolling
messages, these changes are pervasive across all tabs. Firefox is not
restricting the status bar changes to the tab that caused the changes. Thus, I
see the page's scrolling message no matter what tab I am currently viewing.

Reproducible: Always
Steps to Reproduce:
1. Open any page that puts a scrolling message in the status bar, such as the
example page
2. Ensure you have at least one other tab open, and switch to it
Actual Results:  
The scrolling text is written to the status bar of the other tab (which is not
altering the status bar)

Expected Results:  
The status bar should revert to whatever message was in that tab's status bar
(usually a stuck message saying it's getting data from the site when it isn't,
but it is MEANT to say "Done").

Incidentally, when you close the tab that was updating the status bar, the
status bar gets stuck at whatever it said. I closed my test page and now my
status bar just reads "This is a t" even when I change tab or even create a new
tab. Creating yet another tab did finally release the status bar to say "Done"
again.

*** This bug has been marked as a duplicate of 104532 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.