easy way to reset the search window?

RESOLVED DUPLICATE of bug 253331

Status

()

--
minor
RESOLVED DUPLICATE of bug 253331
14 years ago
14 years ago

People

(Reporter: garym, Assigned: p_ch)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

This is a usability comment: I am finding the search editbox almost impossible
to use because it does not have any easy way to clear the search terms.  I can
click, switch to keyboard, Home, ctrl-Del (two hands) and then type, or
triple-click (if it takes, it's tricky).

Someone showed me how to aliase google to 'g', so a new query is now easier if I
just open a new tab, which presents a blank location bar, and type "g keywords";
this is so convenient, I find the search edit box is just wasted real-estate.

Perhaps the design intention is that subsequent searches would be similar to the
previous, and so it keeps the last search current instead of a pull-down history
like the location bar -- this introduces two different data entry paradigms in
edit boxes side by side, and that too seems odd.  Besides, maybe I misunderstand
the intention, but if I want to modify my search query, the google results page
already contains the edit box, so at best the Firefox editbox copy of the query
is redundant.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.



Expected Results:  
IMHO, after each query, the query string should go into a pull-down history
stack and the search window should be reset.
(Reporter)

Updated

14 years ago
Version: unspecified → Trunk

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 253331 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.