Closed Bug 260808 Opened 16 years ago Closed 16 years ago

Allow localization of pref("browser.fixup.alternate.suffix", ".com");

Categories

(Firefox :: General, enhancement)

x86
Windows 2000
enhancement
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: p.franc, Unassigned)

References

(Blocks 1 open bug)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

This pref is set in all.js
http://lxr.mozilla.org/aviarybranch/source/modules/libpref/src/init/all.js#170

Either allow to change the suffix during the build process using #define or
introduce special pref file, where l10n team can change this pref.

Reproducible: Always
Steps to Reproduce:
Blocks: 259167
Maybe ab-CZ.jar!/locale/browser-region/region.properties is good place for this
pref.
Is this really so important that it blocks full localization of Firefox? The
"browser.fixup.alternate.suffix" pref are not used in Firefox by default. Users
have to go to about:config and set the "keyword.enabled" pref to false before
they can use this feature.

More important would be to be able to customize the endings for the Ctrl+Enter,
Shift+Enter and Ctrl+Shift+Enter autocomplete feature. That is bug 221161.
(In reply to comment #2)
> Is this really so important that it blocks full localization of Firefox?
Yes, it is important since users are asking about that (forum.czilla.cz). 

> have to go to about:config and set the "keyword.enabled" pref to false before
> they can use this feature.

This is set to false by default
http://lxr.mozilla.org/aviarybranch/source/modules/libpref/src/init/all.js#51

> Shift+Enter and Ctrl+Shift+Enter autocomplete feature. That is bug 221161.
If you like that bug more, go there and vote for it.
(In reply to comment #3)
> (In reply to comment #2)
> > Is this really so important that it blocks full localization of Firefox?
> Yes, it is important since users are asking about that (forum.czilla.cz). 

OK, but if these users have already gone through the trouble of manually
changing the "keyword.enabled" pref, surely they can change the
"browser.fixup.alternate.suffix" pref just as easily.

> > have to go to about:config and set the "keyword.enabled" pref to false before
> > they can use this feature.
> 
> This is set to false by default
> http://lxr.mozilla.org/aviarybranch/source/modules/libpref/src/init/all.js#51

But it is set to true in
http://lxr.mozilla.org/aviarybranch/source/browser/app/profile/firefox.js#121
which is the relevant line for Firefox.
OK, after reading discussion, this pref is unused in the default config, and so
this bug is WONTFIX for 1.0.  If users update the keyword.enabled pref, they can
also update the suffix pref. Patches are welcome against the trunk to make this
a localized pref.
Assignee: firefox → nobody
Severity: normal → enhancement
QA Contact: firefox.general → bsmedberg
Marking NEW for post 1.0 developement.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Blocks: 221161
> More important would be to be able to customize the endings for the Ctrl+Enter,
> Shift+Enter and Ctrl+Shift+Enter autocomplete feature. That is bug 221161.

I am sure this is the same problem!

"browser.fixup.alternate.suffix" really should be used fot autocompleting,
shouldn't ?
Only my proposal:

From the many Firefox adress completion, some have global meaing:
SHIFT+ENTER -> .net
CTRL+SHIT+ENTER -> .org

I think there is no great reason for change this, but

CTRL+ENTER -> .com
Many companies with the .com suffix have their regional pages on the domain with
regional suffix. We should make this localizable as soon as possible.

Other reason is that IE has CTRL+ENTER completion, which IS localizable (IE
Czech IE completes czilla -> www.czilla.cz).

There is good reason for use existing "browser.fixup.alternate.suffix" and
"browser.fixup.alternate.prefix" for this. Similar as is in Mozilla and as is
using for the URL completion when the keywords are disabled.

What we need is change browser.fixup.alternate.suffix and the
browser.fixup.alternate.prefix from the char prefs to the localizable prefs, so
we can put their values to the e.g. /locale/browser-region/region.properties

This probably means simple patch to the "nsDefaultURIFixup::MakeAlternateURI"
http://lxr.mozilla.org/aviarybranch/source/docshell/base/nsDefaultURIFixup.cpp#372
to avoid regression.

Maybe this sound like minority problem for you. But we are solving this almost
every day in our Czech Mozilla support forum and the only way we are
recommending users is to hack the browser.js directly.
So the Czech users are making their own browser.jar and disributing it themself.
Which is not good and can lead to many problems.

If sb. will change the browser.fixup.alternate.suffix and the
browser.fixup.alternate.prefix to the localizable prefs and patch the
nsDefaultURIFixup (wich I am sure is trivial for the C++ hackers), the patch for
the browser.js is trivilal (I can do it myself).
(In reply to comment #7)
> > More important would be to be able to customize the endings for the Ctrl+Enter,
> > Shift+Enter and Ctrl+Shift+Enter autocomplete feature. That is bug 221161.
> 
> I am sure this is the same problem!

Not really. Maybe I was a little unclear about why I don't think this is so
important for us localizers, and perhaps there are some confusion about what
this pref do. I am sure you are aware of these facts, but just so everyone
understand why I "opposed" the blocking localization status this bug was given,
I will try to explain it here.  

The "browser.fixup.alternate" prefs are only used when you type a word into the
Location bar and press Enter, not when you press Ctrl+Enter. The Enter
autocomplete works by default in Seamonkey, but not in Firefox. If you want to
use this feature in Firefox you first have to disable the default behaviour,
that of performing a Google "I'm Feeling Lucky" search on the string, by going
to about:config and changing the "keyword.enabled" pref to false.

The Ctrl+Enter autocomplete, that IE users are accustomed to, is currently not
controlled by any pref in Firefox. Making it so is bug 221161.

So fixing this bug does not really help the forum.czilla.cz users who wants
Ctrl+Enter to add ".cz" to their string.
Hasse> Thank you for your comment. We have probably different point of view on
this bug. Well, I try to explain this.

Actual situation:
1) There is no possilibity to *localize* URL completion when the keywords adre
disabled (probably you mean this as the only point of this bug)

2) There is no possilibity to *change* and *localize* CTRL+ENTER (IE-like)
completion. This is real bug - bug #221161 (users are asking us how to solve
this), and I have makred it as the dependent on this bug - see later.


My proposal:
- We need one localizable pref (one for suffix and one for preffix) for the
regional based completion. It means both for completion when the keyword are
disabled and for CTRL+ENTER, because - I think - both really have same meaning.

So fixing this bug should help so simply solve bug #221161 as I have proposed in
the comment #8
All l10n prefs can be set in firefox-l10n.js - see bug 264067
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.