Allow localization of 'Safe Mode' shortcut

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
14 years ago
13 years ago

People

(Reporter: p.franc, Unassigned)

Tracking

(Blocks: 1 bug, {l12y})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10

Firefox installer create two shortcuts. One of them is for safe mode. The string
Safe Mode is hardcoded in browser.jst
http://lxr.mozilla.org/aviarybranch/source/browser/installer/windows/browser.jst#65

Introduce a l10n string for that.


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
This is really hard to accomplish:

1) browser.jst is not a localizable file at the present time
2) there are major charset issues, because we cannot depend on MSLU

This will likely not happen before 1.0
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 2

14 years ago
> 1) browser.jst is not a localizable file at the present time

The temporary hack could be:
1) introduce $safeMode variable in browser.jst
2) add 'safeMode = @SAFE_MODE@' line in 
http://lxr.mozilla.org/aviarybranch/source/browser/installer/windows/installer.cfg
3) add #define SAFE_MODE Nouzov\u00FD re\u017Eim in
browser\locales\cs-CZ\defines.inc

> 2) there are major charset issues, because we cannot depend on MSLU

Since it is in JavaScript code which is run by XPI install engine, you have to
use always UTF-8 encoding, otherwise you get mess.

Comment 3

14 years ago
> Since it is in JavaScript code which is run by XPI install engine, you have to
> use always UTF-8 encoding, otherwise you get mess.

The problem is much more complicated. Firstly, these JS files are read as ASCII,
so you have to use \uxxx unicode escapes to get special chars. More importantly,
however, is the fact that even after the JS parses the file (correctly), the XPI
engine cannot effectively convert the filename back into the native charset
needed by windows (due to the lack of MSLU).

Updated

14 years ago
Blocks: 259167
Keywords: l12y
Assignee: bugs → nobody
QA Contact: bugzilla → installer

Comment 4

13 years ago
This is fixed in the new installer (bug 326580). The Safe Mode shortcut can now be localized via the SAFE_MODE string in custom.properties.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.