downloading a large file ~4.5GB fails

RESOLVED DUPLICATE of bug 184452

Status

()

Toolkit
Downloads API
RESOLVED DUPLICATE of bug 184452
14 years ago
10 years ago

People

(Reporter: doug grainger, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040614 Firefox/0.8

i ran into bug 228698 dealing with a restore from backuppc on an http server.  
the file was ~4.5GB.

when the counter in the download manager wrapped back to zero (after counting up
from -2GB), the download failed.  (number of bytes exceeds the range of long)

i've seen the same problem on mozilla-firefox 0.8-12 from debian's testing
distribution, and on mozilla 1.4 on win2k.




Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 184452 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.