Mail received as a forwarded .eml attachment has infinite attachment recursion.

RESOLVED DUPLICATE of bug 203570

Status

MailNews Core
Attachments
--
major
RESOLVED DUPLICATE of bug 203570
14 years ago
10 years ago

People

(Reporter: Andrew Poth, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.7) Gecko/20040616

When receiving forwarded messages that have a previous message as a .eml
attachment, the same attachment appears when the attachment is opened.  Mozilla
is apparently unaware that the attachment is already opened in another window
and makes it appear as if there is an infinite depth of attachments and forwards
of the message.  Typically seen with messages sent from AOL accounts.

Reproducible: Always
Steps to Reproduce:
1. Click on message header to open it in browser window
2. Message body may or may not be blank, but shows a .eml attachment
3 [details] [diff] [review]. Click on .eml attachment
4 [details] [diff] [review]. Attachment opens, and shows itself as a .eml attachment
5 [details]. Click on .eml attachment
6 [details]. etc., ad infinitum

Actual Results:  
Attachment opens, and shows itself as a .eml attachment in the new window.

Expected Results:  
Attachment opens and shows no further attachments if it was at the lowest level
of forwarding, i.e., the original message.

Without examining the message source it is impossible to tell how many levels of
forwarded attachments the message actually contains.  Netscape 4.x mail client
doesn't display this behavior when viewing the same message.

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 203570 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.