graphics vanish when using the find bar

RESOLVED WORKSFORME

Status

()

Toolkit
Find Toolbar
RESOLVED WORKSFORME
13 years ago
9 years ago

People

(Reporter: joe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040922 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040922 Firefox/0.10

After using the find bar once, I try to search again.  I use the hotkey combo
ctrl F, which brings up the find bar.  The old search entry is still visible.  I
immediately try to type in a new entry (assuming that this will overwrite the
old entry), but nothing happens.  I move the cursor down to try to edit the
previous find entry and suddenly the graphics begin to vanish across Firefox. 
They tend to vanish as I move the cursor.  I can click against a completely gray
background and use everthing as normal (back, forward, etc--from what I can tell).

Reproducible: Always
Steps to Reproduce:
1. Open find using ctrl F.
2. Close find bar without deleting the entry.
3. Reopen find.  Try to type a new entry without using the cursor to go down and
delete the old entry.
Actual Results:  
The graphics--icons, url, google search, toolbar info--everything vanishes
leaving the webpage and a gray frame around it.

Expected Results:  
Entered the new find term by deleting the old one.

I apologize if this bug has been reported before.  I did search.

Finally I use Gnome 2.6 on LFS 5.1.  I compiled firefox from source.
I'm having the same problem. Identicaly reproductible.
I'm using KDE 3.2 on a slackware and FireFox 1.0 pt-Br downloaded from the
oficial website.

graphics--icons, url, google search, toolbar info--everything vanishes
leaving the webpage and a gray frame around it. But it still works if I input
some text on url, google search, etc.
Find doesn't work anymore but the find toolbar still closes if I click over the
region where the red close button should be. And it reopens in grey color if I
press ctrl+F again. Even tabbed browsing and navigation works all right.

Everithing, but find toolbar, seems to work.

So, these things make me wonder that this is a rendering bug caused by some
fault in find toolbar's  code.
(In reply to comment #1)
I'm using the following build:
Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.7.5) Gecko/20041118 Firefox/1.0

Comment 3

13 years ago
Happens to me as well:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050610 Firefox/1.0.4
(Debian package 1.0.4-3)

Comment 4

13 years ago
As a followup, there is some user data that is causing this bug to happen.  When
I moved my .gconfd directory, the behavior stopped.  Unfortunately I deleted the
directory accidentally, so I cannot delve deeper into the cause.

Comment 5

12 years ago
Can you provide a screenshot  for this bugger?

Comment 6

12 years ago
This also happens to me. All icons, address bar, Google search box disappear. 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050730 Firefox/1.0.6
(Debian package 1.0.6-2)(In reply to comment #5)
> Can you provide a screenshot  for this bugger?

Comment 7

12 years ago
Created attachment 199962 [details]
screenshot during painting error, marked up

Screenshot during repainting error.  Red markup shows a rectangle that expands
in each direction by 1 pixel for each mouse pointer update.  Mouse was
originally in center of rectangle when errors began (note that error do not
happen when mouse starts in menu bar area, not sure if they continue if mouse
pointer is moved to that area).

Comment 8

12 years ago
Created attachment 199963 [details]
after painting errors have completely nuked the window

this is the final result of the bug.  window is dead, but can be closed and
other windows continue working properly.

Comment 9

12 years ago
Hopefully this will be fixed with the addition of these screenshots.  I know
it's nuked many of my windows, which is annoying because all the tabs and
whatnot that are open are gone.  I'm pretty sure I've had this problem on
windows as well; I can confirm later if it'll help.

Other steps to reproduce:
1. start with empty window
2. ctrl-f to open find bar
3. type "asdf"
4. hit escape
5. ctrl-f
6. type asdf
7. move mouse over window

If you do not type anything the second time the find bar is open, no error
occurs.  It's probably using an old pointer to the previous widget, not
resetting some page-specific variable, or similar.  Please change to confirmed
and fix!

Comment 10

12 years ago
I have exactly the same problem on a Pentium 4M / Fedora Core 4 notebook:

Mozilla/5.0 (X11; U; Linux i686; tr-TR; rv:1.7.12) Gecko/20050922 Fedora/1.0.7-1.1.fc4 Firefox/1.0.7

Thanks,
Alaeddin.
QA Contact: fast.find

Comment 11

11 years ago
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.6) Gecko/20060728 Firefox/1.5.0.6

Seems the last comment on this bug was over a year ago, however this bug seems to have been fixed by the current version of Firefox.  After attempting to repeat the given steps, as well as a few attempts to slightly vary the process, I have come up with the bug being unreproducable every time.  The system I'm currently running on is an XP box. Hopefully someone can confirm the fix. 
Assignee: bross2 → nobody

Comment 12

10 years ago
I don't see it either. Kubuntu Hardy, Firefox 3. Recommend close.
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.