crash on exit [@ 0x01d5521a - nsHashtable::Reset ]

RESOLVED DUPLICATE of bug 200119

Status

SeaMonkey
General
--
critical
RESOLVED DUPLICATE of bug 200119
13 years ago
7 years ago

People

(Reporter: Dimitris Zilaskos, Unassigned)

Tracking

({crash})

Trunk
x86
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040910

about 50% of the times i run mozilla it crashes on exit. That is when the last
window closes . This suddenly started happening in mozilla 1.6 and goes on to
all versions since then. It spits out "The application will be shutdown
blahblah" and talkback agent launches. The crash happens when I close the last
running mozilla window , either download manager , mail or browser.

Reproducible: Sometimes
Steps to Reproduce:
1.start mozilla
2.browse web pages read e-mail download files
3.close all mozilla windows

Actual Results:  
mozilla exe has performed an invalid operation and will be shutdown. Talkback
agent launches

Expected Results:  
the programs should close with no errors

default theme , TB937660Z , TB921204M . Windows XP english Pro, service pack1 ,
all hotfixes.

it looks like to https://bugzilla.mozilla.org/show_bug.cgi?id=185901
Sounds like something in shutdown ordering changed?

Talkback stacks are:

0x01d5521a
nsHashtable::Reset 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 337]
nsHashtable::Reset 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsHashtable.cpp,
line 322]
nsNSSComponent::StopCRLUpdateTimer 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/security/manager/ssl/src/nsNSSComponent.cpp,
line 873]
nsCOMPtr_base::assign_from_qi 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpcom/glue/nsCOMPtr.cpp,
line 97]
nsObserverService::NotifyObservers 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpcom/ds/nsObserverService.cpp,
line 210]
nsProfile::ShutDownCurrentProfile 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/profile/src/nsProfile.cpp,
line 1359]
DoOnShutdown 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 808]
main 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1788]
WinMain 
[d:/BUILDS/tinderbox/Mozilla1.7.3/WINNT_5.0_Clobber/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1809]
WinMainCRTStartup()
kernel32.dll + 0x214c7 (0x77e814c7)

Comment 2

13 years ago
Interesting, my first suspect would be that we're firing profile-shutdown topics
more than once, but I don't know of any particular changes to the seamonkey
startup/shutdown sequencing during the timeframe indicated (between 1.5 and 1.6,
correct?). I'll do some limited bonsai poking, for the moment I'm going to
assume it's not in PSM, although that might well be a bad assumption.

Bug 185901 looks unrelated; bug 182803 looks closer, but still no banana.
Product: Browser → Seamonkey

Updated

13 years ago
Keywords: crash
Summary: crash on exit → crash on exit [@ 0x01d5521a - nsHashtable::Reset ]

Comment 3

13 years ago

*** This bug has been marked as a duplicate of 200119 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Crash Signature: [@ 0x01d5521a - nsHashtable::Reset ]
You need to log in before you can comment on or make changes to this bug.