When closing Firefox 1.0, the process won't die and stays background

RESOLVED DUPLICATE of bug 239223

Status

()

Toolkit
Startup and Profile System
--
major
RESOLVED DUPLICATE of bug 239223
14 years ago
10 years ago

People

(Reporter: T Niemi, Assigned: Benjamin Smedberg)

Tracking

1.7 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Firefox 1.0 Preview Release process won't die, when I'n closing the browser. It
still stays background and I have to kill it with task manager. This feature/bug
enables visiting on HTTP authenticated web-pages without re-authentication. E.g.
if I have visited on autheticated web-page and I close all browsers and starts
firefox again, I'm are able to go back to web-page, which needs HTTP
authentication, without re-authentication. 


Reproducible: Sometimes
Steps to Reproduce:




This bug/feature is very dangerous, because it makes possible to other people to
visit on HTTP authenticated web-pages without authentication, because the
process on background remembers Your username and password..
Assignee: general → bsmedberg
Component: Browser-General → Startup and Profile System
Product: Browser → Firefox
QA Contact: general → bsmedberg
Version: Trunk → 1.0 Branch

*** This bug has been marked as a duplicate of 239223 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Group: security
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.