Firefox blocked by javascript.

RESOLVED DUPLICATE of bug 61098

Status

()

--
major
RESOLVED DUPLICATE of bug 61098
14 years ago
11 years ago

People

(Reporter: durante, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10

Javascript app at http://www.gsmnetsimlock.boo.pl/download_index.html can block
Firefox when you doesn't know correct password. Only killing Firefox process helps.

Reproducible: Always
Steps to Reproduce:
1. Go to http://www.gsmnetsimlock.boo.pl/download_index.html

Actual Results:  
Javascript dialog appears and blocks Firefox until you type correct pass.

Expected Results:  
There should be possibility to close this dialog.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.3) Gecko/20040924
Firefox/0.10

confirming

Comment 2

14 years ago
The same thing happends in all browsers, this is the way the website is
programmed. Not a Mozilla bug. You should contact them about it.
a contextmenu on the alert allowing you to not allow javascript at the next load
would be a solution.
But as comment 2 says this is just bad programming practice.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 66097 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 61098 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.