hover state lost when scroll wheel is used

VERIFIED DUPLICATE of bug 20022

Status

()

Core
Event Handling
--
trivial
VERIFIED DUPLICATE of bug 20022
13 years ago
13 years ago

People

(Reporter: Greg Campbell, Unassigned)

Tracking

1.7 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040922 Firefox/0.10

This bug only appears on the 1.7 and aviary branches; trunk is OK.

An element with a hover state loses the hover state when the page is scrolled
with the mouse wheel.

Reproducible: Always
Steps to Reproduce:
1. Put mouse in a (vertically tall) element with a hover state.
2. Scroll mouse wheel, keeping the pointer within the element.


Actual Results:  
Hover state disappers.

Expected Results:  
Hover state remains.

This could be a regression, but I'd have to do some serious drilling back.
(Reporter)

Comment 1

13 years ago
Created attachment 159987 [details]
test case
(Reporter)

Updated

13 years ago
Version: Trunk → 1.7 Branch
(Reporter)

Comment 2

13 years ago
Looks like this is actually a bug that was fixed between 1.8a1 and 1.8a2, I just
can't find the dupe. Would be a nice port for aviary, if I ever find the
original bug....
Whiteboard: dupeme

*** This bug has been marked as a duplicate of 20022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

13 years ago
Status: RESOLVED → VERIFIED
Whiteboard: dupeme
You need to log in before you can comment on or make changes to this bug.