when rendering arabic with pango and justification, glyphs are all wrong

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
15 years ago
9 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

({testcase})

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

If you render an arabic string when using justification, the glyphs are all
pretty wrong.  Test case coming up.
This test case uses text-align: right to trigger the justification code.
Attachment #159992 - Attachment mime type: text/plain → text/html
justification usually means 'text-align:justify'
text-align:justify with pango mess up hebrew as well.
Chris, duplication with Bug 284927?
Looks like a dup

*** This bug has been marked as a duplicate of 284927 ***
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Reopening per bug 284927 comment 29.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
*** Bug 314592 has been marked as a duplicate of this bug. ***
Does this bug still occur in a recent trunk build?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Whiteboard: CLOSEME 07/01
(In reply to comment #9)

Yes the bug still occur with the build:
"Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a6pre) Gecko/20070617 Minefield/3.0a6pre"

But I checked with the firefox version that come with Fedora 6:
"Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.0.10) Gecko/20070313 Fedora/1.5.0.10-5.fc6 Firefox/1.5.0.10"
and the test case rendred correctly.
I'm using the exact same build (20070617) and it seems to work fine for me.
Amaoui, could you attach a screenshot of the error please?
Also, what does the menu View->Character Encoding say it is?
Which font preferences are you using? (a screenshot of the Preferences->
Content->Font&Colors:Advanced dialog would help)
Assignee: blizzard → nobody
Status: REOPENED → NEW
Component: GFX: Gtk → GFX: Thebes
Keywords: testcase
QA Contact: ian → thebes
Whiteboard: CLOSEME 07/01
(In reply to comment #11)
> Amaoui, could you attach a screenshot of the error please?
done

> Also, what does the menu View->Character Encoding say it is?
Both browsers detected it as utf-8

> Which font preferences are you using? (a screenshot of the Preferences->
> Content->Font&Colors:Advanced dialog would help)
I'm using MS Times New Roman 

This bug as reported is now WORKSFORME. (We have bug 635639 with some fonts, but it doesn't depend on justification)
Status: NEW → RESOLVED
Closed: 15 years ago9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.