Onchange Event not fired on select box when changing options by keyboard

RESOLVED DUPLICATE of bug 126379

Status

()

Core
DOM: Events
RESOLVED DUPLICATE of bug 126379
13 years ago
13 years ago

People

(Reporter: Hercules, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.1) Gecko/20040707

The onchange event is not fired when the options of the selectbox are changed by
keyboard up and down arrows. When this is done by mouse, this works just fine.
This works in IE but not in mozilla.

Reproducible: Always
Steps to Reproduce:
1. Create a simple web form with event code on the onchange of a select box
2. Change the selectboxes value by keyboard
3. Here you go ... The event code is not executed

Actual Results:  
The code that is hooked on the onchange event of the selectbox is not executed.

Expected Results:  
Fired the event as it does by clicking on the selectobox by mouse.
It works for me using the testcase from bug 260850.
https://bugzilla.mozilla.org/attachment.cgi?id=159791&action=view

Works in Mozilla1.7 and in the latest 1.8a build of Firefox.

Maybe you could add an attachment which shows the bug?

Comment 2

13 years ago
If the select has a size="1" (or no defined size), then keyboard arrows do not
fire the onchange event. And then, I believe that would be bug 126379.
Mozilla 1.8a4 build 2004092505 under XP Pro SP2 here. 

Comment 3

13 years ago
Correct.

*** This bug has been marked as a duplicate of 126379 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.