Error msg on start: "Java Plug-in for Netscape Navigator should not be used in Microsoft IE. Please use Java Plug-in for Microsoft IE instead." CPu goes to 100%

VERIFIED DUPLICATE of bug 83376

Status

()

defect
--
critical
VERIFIED DUPLICATE of bug 83376
15 years ago
15 years ago

People

(Reporter: Charles, Assigned: bugzilla)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040911 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040911 Firefox/0.10

I originally received this message after installing Firefox 1.0PR over .0.9.2. 
Removing and re-installing did not fix the problem.  Only after deleting the
Profiles folder did Firefox start. Today, after installing the Bug-me-not
extension, I received the same error "Java Plug-in for Netscape Navigator should
not be used in Microsoft IE. Please use Java Plug-in for Microsoft IE instead."
and the CPU goes to 100%.  Deleting the old profile (moved it to another
location)  fixed the problem.  However, the only items from the old profile that
I could copy without generating this error was the bookmarks.htm file.  I've
installed the bug-me-not extension with any problems in the new profile.

Reproducible: Didn't try
Steps to Reproduce:
1.copied the cert8.db, cookies.txt, defaults.ini, history.dat, key3.db and
prefs.js from my old profile to the new profile
2. Try to start firefox
3. receive error message and CPU goes to 100%

Actual Results:  
Got the nmessage "Java Plug-in for Netscape Navigator should not be used in
Microsoft IE. Please use Java Plug-in for Microsoft IE instead." and CPU went to
100%

I suspect that something in the extension install munges up the profiles.

Expected Results:  
Not munged up the profile.



I have seen at least 3 reports of this error on the Internet.  Mostly, I'm
reporting this error so that the "fix" of removing the profiles folder will be
known and that there is a problem with Firefox occasionally munging up the
profiles.  I lost everything the first time I got this error.  Now I can get
back my bookmarks but lose all other information (history, cookies, passwords).
this sounds like the useragentswitch extension having set the useragent to IE6 
(Reporter)

Comment 2

15 years ago
(In reply to comment #1)
> this sounds like the useragentswitch extension having set the useragent to IE6 

I was using Useragent and leaving it set to IE6.  Thanks.  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Updated

15 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Comment 3

15 years ago

*** This bug has been marked as a duplicate of 83376 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.