when folder selected, create new {bookmark, folder, sep.} should be created inside folder

RESOLVED DUPLICATE of bug 222883

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 222883
14 years ago
12 years ago

People

(Reporter: Søren Munk Skrøder (extended hiatus), Assigned: vlad)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; da-DK; rv:1.7.3) Gecko/20040913 Firefox/0.10

For now, when you select a folder in the bookmarks sidebar (or in Bookmarks
Manager) and then uses the context-menu (right-click) to create a new bookmark,
folder or seperator, the new item will be created _after_ the folder - thus
putting it _on the same level_ in the hierachy....

It should, however, create the new item within the folder, since it's a container

Reproducible: Always
Steps to Reproduce:
1. open Bookmarks Sidebar
2. select a folder
3. use context menu to create a new item (e.g. a new bookmark)

Actual Results:  
the new item is created besides the folder - not inside the folder :-(

Expected Results:  
since a folder (container) was selected, the new item should have been created
_inside_ the folder

*** This bug has been marked as a duplicate of 222883 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.