about:buildconfig should be localizable through .dtd file

RESOLVED WONTFIX

Status

()

Firefox
Build Config
--
enhancement
RESOLVED WONTFIX
14 years ago
9 years ago

People

(Reporter: Pavel Franc - Mozilla.cz, Unassigned)

Tracking

Trunk
Future
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; cs-CZ; rv:1.7) Gecko/20040803 Firefox/0.9.3

This is a split of bug 257375.

Piotr Komoda <gorky@neo.pl> reported

Having translated about:mozilla and about:buildconfig pages requires from us
(localizers) to "hack" toolkit.jar and change mozilla.xhtml and buildconfig.html
in \global. Now, when the whole build process of localized official releases is
covered by mozilla.org, we can't do this modification. Besides, even draft of
trademark policy doesn't allow us to do so.  The easiest way to solve the
problem and (by the way) to make L10n teams life easier is to let us translate
contents of those abouts via .dtd or .properties files, just like in
about:plugins case.... 

And Benjamin Smedberg <bsmedberg@covad.net> commented
So I'm happy to create a patch for about:mozilla (it's mostly done in my tree),
but about:buildconfig isn't going to happen (besides, if you're geeky enough to
read about:buildconfig, you're gonna have to know the English word for
"compiler" anyway).

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

14 years ago
IMHO this is still valid l10n bug.

Please don't close it. Just consider it as a  WONTFIX for 1.0, assigne it to
nobody@mozilla.org and mark it as NEW for post 1.0 developement.

Comment 2

14 years ago
You make the patch, or find a volunteer. I'm not wasting my time on something
like this which is not part of the Firefox UI.
Assignee: bryner → p.franc
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
QA Contact: asa → bsmedberg
Target Milestone: --- → After Firefox 1.0
Version: unspecified → Trunk

Comment 3

14 years ago
CCing Gandalf. Maybe he will try to make the patch...
(Reporter)

Comment 4

14 years ago
Created attachment 172570 [details] [diff] [review]
Replace buildconfig.html with buildconfig.xhtml

Comment 5

14 years ago
Comment on attachment 172570 [details] [diff] [review]
Replace buildconfig.html with buildconfig.xhtml

This will break seamonkey without changes to xpfe/ as well.
Attachment #172570 - Flags: review-

Comment 6

13 years ago
Created attachment 187213 [details] [diff] [review]
buildconfig.xhtml in toolkit and xpfe

just added xpfe version of buildconfig. File buildconfig.dtd is duplicated in
xpfe/global/resources/locale and toolkit/locales, but so was
buildconfig.html.in in xpfe/global and toolkit/content, so I hope it should not
be problem.
Attachment #187213 - Flags: review?(benjamin)

Comment 7

13 years ago
Comment on attachment 187213 [details] [diff] [review]
buildconfig.xhtml in toolkit and xpfe

r=me, but this is *not* approved for the 1.8 cycle, it must wait for 1.9 to
open (i.e. this will not be in Firefox 1.1).
Attachment #187213 - Flags: review?(benjamin)
Attachment #187213 - Flags: review+
Attachment #187213 - Flags: approval-aviary1.1a2-

Comment 8

13 years ago
Patch still works with current trunk.
Maybe it would be an idea to add some id attributes around the XHTML to make it easier (and more reliable) to parse?

Comment 10

13 years ago
Really, nobody ought to be parsing about:buildconfig... if you need the information in it, we ought to provide an API for getting that information (and bugs are filed on that).
QA Contact: benjamin → build.config
(Reporter)

Updated

9 years ago
Assignee: p.franc → nobody
Since about:support has a link to about:buildconfig, I think this page should be localized as well as it's about:support or about:plugins (it's linked from ab:support too)

Ideas?
I'm not sold on the idea that translating about:buildconfig helps support.

Talking about modifications to about:buildconfig, it'd be nice to have the localization source info in it, and for multi-repo apps, the revisions of the app repos in addition to the toolkit one.

Comment 13

9 years ago
I really don't think we should spend localizer time on this file, and this bug should be WONTFIX. I don't know whether multi-repo apps/l10n repo IDs, etc would be possible, but it should be a different bug in any case.
Sounds good. The comm-central etc bits are covered by bug 456360.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.