If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Install script template for other locales never register DOMI or HELP (even when they are present)

VERIFIED FIXED

Status

()

Firefox
Installer
VERIFIED FIXED
13 years ago
12 years ago

People

(Reporter: Vincent Béron, Assigned: Benjamin Smedberg)

Tracking

({fixed-aviary1.0})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.2) Gecko/20040808
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.7.2) Gecko/20040808

The ab-CD.jst files in browser/installer/{unix,windows}/ab-CD.jst (used as
templates for the install.js in the langpack xpi for the full installer) never
register DOMI or HELP, even if LOCALE_HAS_DOMI or LOCALE_HAS_HELP is set in
defines.inc.
The install.rdf template in browser/locales/generic/install.rdf (for standalone
xpi as extensions) do have those checks.
Fix: add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP to ab-CD.jst.

Reproducible: Always
Steps to Reproduce:
(Reporter)

Comment 1

13 years ago
Created attachment 160361 [details] [diff] [review]
Add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP in ab-CD.jst
(Reporter)

Comment 2

13 years ago
Comment on attachment 160361 [details] [diff] [review]
Add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP in ab-CD.jst

Requesting review from bsmedberg
Attachment #160361 - Flags: review?(bsmedberg)
Attachment #160361 - Flags: approval-aviary?

Comment 3

13 years ago
This should go to bsmedberg
Assignee: bugs → bsmedberg
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 4

13 years ago
Comment on attachment 160361 [details] [diff] [review]
Add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP in ab-CD.jst

Please do not ifdef autoconfig. That ifdef in toolkit/ is a temporary measure
for thunderbird, autoconfig is considered an essential part of firefox.

You need to fix up the makefile that builds these also, because right now it
does not include defines.inc. See
http://lxr.mozilla.org/aviarybranch/source/browser/installer/windows/Makefile.i
n#91
which needs the -I flag from
http://lxr.mozilla.org/aviarybranch/source/browser/installer/unix/Makefile.in#8
5
Attachment #160361 - Flags: review?(bsmedberg)
Attachment #160361 - Flags: review-
Attachment #160361 - Flags: approval-aviary?
(Reporter)

Comment 5

13 years ago
Created attachment 160365 [details] [diff] [review]
Add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP in ab-CD.jst (take 2)
Attachment #160361 - Attachment is obsolete: true
(Reporter)

Comment 6

13 years ago
Comment on attachment 160365 [details] [diff] [review]
Add checks for LOCALE_HAS_DOMI and LOCALE_HAS_HELP in ab-CD.jst (take 2)

Review points taken into account.
Requesting review from bsmedberg for revised patch
Attachment #160365 - Flags: review?(bsmedberg)
Attachment #160365 - Flags: approval-aviary?
(Assignee)

Updated

13 years ago
Attachment #160365 - Flags: review?(bsmedberg)
Attachment #160365 - Flags: review+
Attachment #160365 - Flags: approval-aviary?
Attachment #160365 - Flags: approval-aviary+
(Assignee)

Comment 7

13 years ago
Fixed on branch, doesn't apply (yet) to the trunk.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed-aviary1.0
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → VERIFIED
QA Contact: bugzilla → installer
You need to log in before you can comment on or make changes to this bug.