<input type="file" /> File Input form control enhanced with Drag+Drop functionality

RESOLVED DUPLICATE of bug 50660

Status

()

Firefox
Shell Integration
--
enhancement
RESOLVED DUPLICATE of bug 50660
13 years ago
13 years ago

People

(Reporter: Ben Ward, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040919 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.3) Gecko/20040919 Firefox/0.10

Something which lacks from both Firefox and IE on Windows is the ability to drag
a file onto the text-input area, when faced with an "Attach a File" type form.

In all occasions you are forced to hit "Browse" or manually type the full path
to the file.

It would be an excellent enhancement to allow a file to be dragged from an open
folder or the desktop, onto a File input form control and for Firefox to get the
path to that file and insert it into the form.

Currently an 'unavailable' cursor appears when files are dragged over these
controls.

Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

13 years ago

*** This bug has been marked as a duplicate of 50660 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.