Closed Bug 262112 Opened 16 years ago Closed 16 years ago

rendering space and scrollbars don't account for negative margins on body

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 6976

People

(Reporter: dsb, Unassigned)

Details

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7) Gecko/20040616

Mozilla doesn't seem to handle negative body margins completely.  Although
it does seem to move body content relative to where it would have been 
without the negative margins, Mozilla does not adjust the overall size of the 
pane that is scrolled by the scroll bars or adjust the scrollbar parameters.  

The result is that the edge of the page is not visible, and if the page is 
wide or tall enough to require a scroll bar, the scroll bar doesn't scroll
the page far enough to see the all of the content.




(Not that I want to compare things to IE, but I did check, and IE displays
all the content and, when the scroll bar is need, scrolls all the way to 
the left.)


Reproducible: Always
Steps to Reproduce:
1. View an HTML page whose body element has negative margins (from CSS).
   (See attachment.)

Actual Results:  
The edge of the page (the content beyond the natural body boundary) isn't 
displayed, and the page can't be scrolled to see it.

Expected Results:  
It should have expanded the pane on which it rendered content to account
for the larger body, and should have computed any scrollbar parameters
such that scrolling would scroll over the whole expanded distance, not just
the natural distance (without the negative margins) of the body.
Notice now scrollbar won't scroll all the way to the left.
(Narrow your window if you don't initially see a horizontal
scrollbar.)
Whiteboard: DUPEME

*** This bug has been marked as a duplicate of 6976 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.