When saving a W3C Validated XHTML Page Mozilla does not keep the page Valid

RESOLVED DUPLICATE of bug 205264

Status

()

Core
Serializers
RESOLVED DUPLICATE of bug 205264
14 years ago
14 years ago

People

(Reporter: Stephen Hind, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: 

Mozilla always strips the forward-slash at the end of a self-closing tagan
example follows (http://www.cumbria-apprenticeships.co.uk/ used as example site):

Original source code (as seen in "View Page Source")
<meta name="DC.title" content="Cumbria Prospectus" />

Saved source code (open saved file and "View Page Source")
<meta name="DC.title" content="Cumbria Prospectus">

Reproducible: Always
Steps to Reproduce:
1. Save any W3C Validated XHTML page
2. Open saved page
3. Try to validate (http://validator.w3.org/) = no longer valid XHTML

Actual Results:  
The problem occurs

Expected Results:  
The saved page should have validated the same as the original.

It makes no difference if you have "Retain Original Formatting" option set

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 205264 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.