Arrow key navigation doesn't work in CookieViewer tree

VERIFIED WORKSFORME

Status

()

P3
normal
VERIFIED WORKSFORME
19 years ago
19 years ago

People

(Reporter: nathan, Assigned: bugs)

Tracking

Trunk
x86
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Build ID 2000012520, Win NT 4.0 SP5

Edit / Preferences / Advanced / Cookies
Press View stored Cookies (twice the first time it jumps - a known bug).
I have a fairly long list of cookies 20 or 30 perhaps.

Clicking on a cookie in the list and pressing the up and down cursor should
navigate through the list but they don't.

Comment 1

19 years ago
This one sounds like a dup of bug 25432 so I'm marking it as such.  If you think 
this is a separate bug, then reopen.  If the browser is hung at this point it is 
a dup, otherwise it might be a separate bug.

*** This bug has been marked as a duplicate of 25432 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 2

19 years ago
No the bug you mention is all about the cookies killing the browser.  This is 
not a browser hang situation, its just the the dialog doesn't react to key 
presses - It should scroll through available items.  This is probably a list box 
problem and not specific to cookies, I don't know.

Comment 3

19 years ago
Ah, you're right.  I didn't read your description carefully enough.  You are 
complaining that you can't navigate in a list with the up/down keys and not 
about a hang.

Yes, this is a dialog issue and not a cookie issue.  Reopening and reassigning.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 4

19 years ago
Bugzilla is forcing me to say something otherwise it won't let me reassing 
the bug.  But I just said that I'm reassing in my last comment.  Bugzilla 
wouldn't let me reopen and reassign in submit so I have to do it twice and now I 
have to say something about it.  OK, have I said enough. ;-)
Assignee: morse → don
Status: REOPENED → NEW
Component: Cookies → HTML Dialogs

Comment 5

19 years ago
Moving to XP Toolkit/Widgets.
Component: HTML Dialogs → XP Toolkit/Widgets

Comment 6

19 years ago
M16.
Assignee: don → ben
Target Milestone: M16
Summary: Keys don't work in cookie list → Arrow key navigation doesn't work in CookieViewer tree
worksforme 02/22/00
Status: NEW → RESOLVED
Last Resolved: 19 years ago19 years ago
Resolution: --- → WORKSFORME

Comment 8

19 years ago
Works for me too.

Comment 9

19 years ago
.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.