Closed Bug 262290 Opened 16 years ago Closed 14 years ago

XML xml-stylesheet alternate XSL stylesheet not supported in switcher (xml-stylesheet alternate="<yes|no>")

Categories

(Firefox :: General, enhancement)

x86
All
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 126841

People

(Reporter: analogAI, Assigned: bugzilla)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040803 Firefox/0.9.3

The xml-stylesheet alternate attribute is not supported in the stylesheet
switcher.  There should be a switcher for XSL stylesheets in addition to CSS
stylesheets.

XML xml-stylesheet alternate attribute is defined at W3C here:
http://www.w3.org/TR/xml-stylesheet/

Reproducible: Always
Steps to Reproduce:
1. load xml file with alternate xsl stylesheet specified
<?xml-stylesheet alternate="no" title="Screen View" href="a.xsl" type="text/xsl"?>
<?xml-stylesheet alternate="yes" title="Print View" href="b.xsl" type="text/xsl"?>
2. currently I cannot find any way to switch between the two xsl stylesheets
3. workaround by saving the file locally and edit the alternate"<yes|no>" attribute

Actual Results:  
only switcher available is for alternate css styles

Expected Results:  
two stylesheet changer icon+menus in the statusbar, one for CSS and one for XSL
Blocks: altss
In fact, I think this is a duplicate of bug 126841.
it is indeed.

*** This bug has been marked as a duplicate of 126841 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.