Events added for Sept.30,2004 in multiweek/month view are not visible in week/day view

RESOLVED DUPLICATE of bug 261890

Status

RESOLVED DUPLICATE of bug 261890
14 years ago
12 years ago

People

(Reporter: wjhelder, Assigned: mostafah)

Tracking

Details

Attachments

(4 attachments)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; rv:1.7.3) Gecko/20040913 Firefox/0.10
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a4) Gecko/20040907 Mozilla Sunbird/0.2a

When I add an event for September 30, 2004, in multiweek view or monthview,
these events are not visible in dayview or weekview.

Reproducible: Always
Steps to Reproduce:
1. switch to monthview of multiweekview
2. doubleclick on Sept. 30, 2004 to add an event
3. switch to dayview or weekview

Actual Results:  
The event is not visible in dayview and weekview, but is visible in
multiweekview and monthview

Expected Results:  
Show the event in all views.
(Reporter)

Comment 1

14 years ago
Created attachment 160720 [details]
Screenshot of missing event in dayview
(Reporter)

Comment 2

14 years ago
Created attachment 160721 [details]
Screenshot of missing event in monthview
(Reporter)

Comment 3

14 years ago
Created attachment 160722 [details]
Screenshot of missing event in multiweekview
(Reporter)

Comment 4

14 years ago
Created attachment 160723 [details]
Screenshot of missing event in weekview

Comment 5

14 years ago
Are any errors reported in the JavaScript console?
(select 30 sep 2004, go to month view, clear console, then go to week view)
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
Error: dayEventEndList[eventEndListIndex] has no properties
Source File: chrome://calendar/content/calendarWindow.js
Line: 813

Comment 7

14 years ago
Happens on my Sunbird 0.2RC1 on Mac OSX as well. Even if I add an event in day
view, it does not show up until multiweek.

Comment 8

14 years ago
I am also experiencing a similar problem with days between February 23 - 26 2005

Nothing will appear for the 23rd in "Day View", and only the "All Day Event"
will appear in "Week View".  The "Multi-week" and "Month view" work fine for
this date.

"Events" and "All Day Events" on 24th, and 25th are not displayed in "Week View"
but are displayed in "Day View", "Multi-week" and "Month view"

The "All Day Event" on the 26th will not appear in "Week View" but displays
properly in "Day View", "Multi-week" and "Month view"

These issues are inconsistent with any views I have checked.  The program has
successfully displayed "events" and multiple "All Day Events" for the same day
before and after the above issued dates.

Comment 9

14 years ago
(In reply to comment #6)
> (In reply to comment #5)
> Error: dayEventEndList[eventEndListIndex] has no properties
> Source File: chrome://calendar/content/calendarWindow.js
> Line: 813

The error message in the JavaScript console makes this appear like it might be
the same as bug 261890 (the line number might have changed between builds due to
changes in the file).  

Possible Workaround:  If so, then giving all zero-duration events a duration of
1 minute or longer should fix the program.  (Note: in day and week view height
is proportional to duration, so 1 min may appear as a line, and longer will be
more visible.)

Wim, does this workaround fix the program for you?  If so, please resolve this
bug as a duplicate of bug 261890.



(Reporter)

Comment 10

14 years ago
(In reply to comment #9)

This is indeed the same as bug 261890.
As soon as one zero-duration event is added, all other (even non zero-events) 
are not visible anymore in day and weekview.


*** This bug has been marked as a duplicate of 261890 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
The bugspam monkeys have been set free and are feeding on Calendar :: General. Be afraid for your sanity!
QA Contact: gurganbl → general
You need to log in before you can comment on or make changes to this bug.