Closed Bug 262458 Opened 15 years ago Closed 15 years ago

"sudo firefox" causes my bookmarks to fry!

Categories

(Firefox :: Bookmarks & History, defect, critical)

x86
Linux
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 236593

People

(Reporter: hoborocks, Assigned: vlad)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; rv:1.7.3) Gecko/20040914 Firefox/0.10

I wanted to install updates to Firefox so I did sudo firefox - I believe that's
where the problem happened (i also logged in as root and ran firefox but i doubt
that's the problem).

After closing down my sudo-ne firefox, I started firefox as my normal user
(hoborock) and my bookmarks were GONE!  All that's left is the Bookmarks Toolbar
Folder and that's empty...And now /home/hoborock/.mozilla/ lists the following:

hoborock@BigRig .mozilla $ ls -lah
total 22K
drwxr-xr-x    5 hoborock users  216 Sep 12 15:34 .
drwx------  106 hoborock users 6.2K Oct  1 10:57 ..
drwx------    3 root     root    80 Aug 18 23:36 Default User
-rw-r--r--    1 hoborock users 1.6K Sep 17 10:05 appreg
drwxr-xr-x    3 hoborock users   80 Jan 31  2004 default
drwxr-xr-x    3 hoborock users  144 Sep 20 08:01 firefox
-rw-r--r--    1 hoborock users 5.1K Oct  1 10:52 mozver.dat
-rw-------    1 hoborock users 2.4K Sep 16 00:25 pluginreg.dat

Where the heck did Default User come from?!  (Luckily I just found an old backup
of my bookmarks...)

Reproducible: Always
Steps to Reproduce:
1. "sudo firefox" (enter password if necessary)
2. In this step, I updated Talkback and some other utilities.
3. Now start firefox as a normal user.

Actual Results:  
Lost my bookmarks...

Expected Results:  
Done nothing of the sort!

All of the files have the date August 18, around 23:36 (definitely not when I
did this, nor when I installed firefox, nor any sort of important milestone)

*** This bug has been marked as a duplicate of 236593 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.